Support Website Contact Support Blog

2 layers in point cloud

I have 2 layers of points in the point cloud. The upper layer have detail of the terrain such as roads and mine pits, but much less points than the layer below. The lower layer has much more detail, however it seems to terminate (last image), with the upper layer continuing to cover a majority of the survey area.

How do I deal with cleaning this up? Add mtp and reprocess, or delete the upper layer where there is overlap and re-run step 3?

 

Hi APEX Geoscience, 

Thanks for posting screenshots and for describing the issue. Could you also post the quality report of your project (e.g. a link to a Google Drive or Dropbox document)? This would give some more hints on what can be improved. 

I would not recommend to delete the points, because the model was not correctly calibrated, so it might not be accurate even if the points are deleted. Instead, I would try one of the following (once I see the quality report I might be able to tell more): 

  • Add Manual Tie Points (MTPs) and mark them in images that were used in the reconstruction of both layers. I would add about 5 and then click Process > Rematch and Optimize. Here is how MTPs can be added: https://support.pix4d.com/hc/en-us/articles/202560349

  • This type of issue tends to happen if there are more than one flight over the same area with different illuminations, which results in the software having some issues recognizing the same points. The project seems also rather large, so you could try splitting the project into smaller parts (that should still overlap between each other), process step 1. separately for each of them, and then merge the project. More about that here: https://support.pix4d.com/hc/en-us/articles/202558529

Note, you can make a copy of your project with Project > Save Project As…, so that you can try changes without losing your current project. 

Same thing happened in this thread, https://community.pix4d.com/t/3387-My-project-was-divided-into-two-blocks-with-a-vertical-gap-of-about-5-meters#gsc.tab=0 and since it was just 1 block, the MTP option didn’t work.

I bet this project has multiple cameras like the other one and thus we are seeing a trend where letting your camera run in “auto” across significantly different conditions will seriously hurt processing.  Once we see the quality report here then we will see how similar these two projects are in their data collection variables.

I had added 5 manual tie points. I optimized and am now re-processing steps 2-3. I cannot upload the quality report, as I sometimes have an issue where the .pdf does not generate ( issue for another time). Step 1 did generate 3 blocks, georeferencing has a mean RMS erros of 1.615m. This is including 5 3D GCP. I cannot remember is this was an issue with the original processing. I will wait until it completes to look at the final result.

APEX, even a screenshot of the first page of the Quality Report helps.  Since you have 3 blocks then those certainly need MTPs or done as sub-projects and merged.

When using MTPs, I suggest trying to match with at least 7-8 images with a preference of 10-12 to achieve the best results.

If you need a more in-depth look at your data then shoot me an email at Adam.Jordan@nhiae.com so I can process on my “super” computer.  I am pretty sure my rig is better than what Pix4D has in-house :) 

1 Like

@APEX Geoscience: how did it go? I agree with Adam that blocks should be removed, usually adding MTPs between them and to Process>Reoptimize helps. If they are not removed, you will have different parts of the project that are optimized separately, which results in some areas not perfectly fitting together. 

How should I go about removing blocks? Removed the physical photos that make up those areas? remove the key matches or points from the point cloud?

I added 12 MTP @ ~ 15-30 photos matched for each. The results is exactly the same as before. I noticed int he orthomosaic that where these 2 layers overlap there is a contrast difference. I expect there was either a large shadow, or these 2 layers were flown on different days with a vast lighting difference.

But even if there was a difference in lighting, wouldnt the georeferencing of the raw image still have an elevation of roughly the same value? If one set of photos was flow at 100’ and the next day the same area was photoed again @ 300’. Wouldnt Pix4D match them together based on the terrain features and give the ground surface the correct elevation across both sets of photos?

Thanks for the help everyone

APEX, unfortunately with the project I was given the photos for in the link above, I couldn’t fix it with MTPs.  Every project is different but this is VERY similar to the one I helped Roy with so you can either process as sub-projects and merge or fly new pictures with consistent exposure and focus.

The geo-referencing is just an initial start, which I have had it a few hundred feet wrong and Pix4D fixes it by visual matching.  I am not the software coder here but I am 99% sure that GPS won’t over-ride the flaws in visual matching (GPS can be off by 5 meters and visual matching is 1X-3X GSD)…I even tried setting the MTP to GCP and no luck there either.

Agreed with Adam. 

APEX, normally blocks can be removed by adding MTPs and using Process > Reoptimize. When there are two layers like this, Process > Rematch and Optimize should help merge the two layers. However, if these two did not work, I would suggest the merging procedure as in the first comment. It’s a shame that the quality report does not get generated, would have been helpful.