Quality report export error


I’ve been having a strange error today in Pix4Dmatic, when trying to export the quality report, it fails and gives this error (taken from the log):

[2023-06-13 15:01:14][01%CPU][10%RAM]Export quality report Failed with code: 0 and error ‘Process operation timed out’ :

I tried on another computer from my office and same result…

I’ve never had this error before and haven’t done anything different from previous processing.

Can anyone help ?

Hi serveur,
Can you attach your log file to this post? We will take a look and let you know what we see.

Sure, here it is.

2023-06-13_15-00-20.txt (2.0 KB)

I’m also getting the same error, tried a few different directories. I’ll upload a log via a support ticket now

Hi Luke,

Did you get any answer ?

Hi serveur_calcul,

I got a fairly quick response from the Support team, and uploaded the files requested, although my case is still being investigated by the looks of it.

I’m no IT guy, although I had a quick look at what was going on to make sure it wasn’t something caused by my PC. If you’re IT savvy and really stuck, I managed to unpack a bit of how it appears to work, purely out of desperate need to obtain some report attributes, and I can see bits of where it’s failing although I’m not sure of the cause.

From what I can gather, selecting ‘Export’ in Pix4DMatic appears to generate the quality report in parts in HTML and then calls an external program wkhtmltopdf.exe (which formats & converts the report to PDF).

If you just need a few critical items out of the report that isn’t visible within Pix4DMatic, it appears to temporarily:

  1. Generate a Report Header in HTML
  2. Generate a Report Footer in HTML
  3. Generate a CSS file (defines the formatting of the HTML page layout)
  4. Generates a HTML File with the report content itself.
  5. Runs an open source program called wkhtmltopdf to merge the header, footer and report into a clean formatted PDF file.

For my scenario, wkhtmltopdf runs quite slow and appears to generate buffer overflows, retries and then fails to complete a PDF report, hence the problem I experienced.

These files are temporarily created in

Of which it attempts to cleans up these temporary files after, except if the export failed; doesn’t always manage to do so properly.

My Temp directory was full of raw report HTML files that were from incomplete PDF generation. So if you need to check a few things in the quality report that wasn’t in the application, look for a file in that temp directory created around the time you chose to Export.

The file appears to be prefixed with ‘wk-temp-’ and is a html file, so you can open it in Edge, Chrome, etc.

E.g. wktemp-cbf07d7e-ced8-41ef-bf21-6fd1781de09f.html

I’d probably try and diagnose further to see if there is some other software on my PC causing the issue, although given this is very expensive software I’ve paid quite alot for, for it to only fail, I’m kinda not too interested in fixing myself and probably wouldn’t be able to if the problem lies within Pix4DMatic initiating it anyhow.

Edit: One thing I did notice is that Pix4Dmapper also uses the same technique for PDF generation (albeit a slightly older version) and it also doesn’t generate the PDF (although I hadn’t noticed until now as all the info is in the application). So that’s kinda interesting. However, the difference with Pix4DMapper is I can replicate the PDF creation that it used by running the exact same command argument that it generated to produce the PDF. It just takes a while longer (very slow for 6 pages) and then completes. So I’m guessing something is causing wkhtmltopdf.exe to run very slow but it does work, just Pix4D applications don’t wait for it to complete if running slow. No idea why it does run slow.

However, I would be happy to help if they need someone to assist with reproducing the error and testing fixes; given it might not be that easy to find again. Except for your PC and mine so far which appear to consistently produce this error :slight_smile:

Hi serveur_calcul,

Given it looked like this was going to take a while for this to be resolved. I figured, I’ll just have to work it out on my own as it’s too costly to wait. Fortunately in Pix4DMapper, the report is quite good, so I’ve never needed it in PDF. Coupled with Mapper providing cleaner logic that made it easier to replicate the scenario.

Basically the wkhtmltopdf open source app that Pix4D uses to generate PDFs is known to have issues in various environments, and hasn’t been updated in years.

I tried the same in Pix4DMapper and re-ran the executable with the arguments that Pix4D mapper passed thru and it worked just fine, albeit really slow. A quick google search as to why it was running slow…

This fix worked for me across all Pix4D PDF generation tasks in Survey, Matic & Mapper.

The problem in my scenario was I hadn’t installed any printers (it’s 2023, not everyone prints these days). Therefore Windows set the default printer to one that I don’t use, and it had only windows default drivers installed as I don’t print, ever.

Note: This is standard windows settings these days ‘Allow Windows to manage my default printer’.

Issue I experienced: wkhtmltopdf can’t handle this properly and therefore runs slow.

Result: Pix4D exception handling with this 3rd party app appears to not cater for slow performance of it, therefore just threw a generic error that processing timed out.

I changed my default printer and the turned off Windows managing this in Printer Settings, then the crappy little PDF executable ran faster and therefore Pix4D completed the report successfully.

Hopefully in future versions exception handling and error messaging is enhanced, and/or more reliable PDF functionality is added.

Please note: This is just a workaround that solved my situation, as you may end up messing up your default printer settings to something that doesn’t work for you. But it got it working and I don’t print, so I’m okay.

Bonjour tout le monde,

J’ai rencontré le même problème que vous, concernant l’export du rapport de qualité.
Toute fois j’ai une solution à vous proposer et qui fonctionne (en tout cas pour moi) .
Je travaille sous Windows 11, la chose toute simple à faire pour obtenir le rapport est de déconnecter votre PC du wifi.

Vous verrez à ce moment là, une petite latence, mais qui après coup arrive à me sortir le “précieux” PDF. :wink:

J’espère en tout cas que cela pourra aider un maximum d’entre vous.

@luke2 thanks for your thorough investigation and its documentation in the community. The developers had a look and made a patch that is in the stable release 1.47.1: Download PIX4Dmatic photogrammetry software.

Can you please try with the new version and let us know if the issue is still there (anyone who had the issue)? Thanks!

1 Like

Works fine for me, thank you much appreciated. Impressive turnaround on putting a fix into a release so quickly.

1 Like

Hi all,

For those who had the same issue, please download the latest stable version 1.47.1.

You can also see our technical release note on what bug fixes and improvements we have for this version here:

Technical release notes - PIX4Dmatic

Hope this helps!

Rosana (she/her)

1 Like

We are having the same issues with Pix4Dmapper, is the latest version of Mapper also supporting this or is a patch in the making?

Hi @bert,

The fix discussed previously was for PIX4Dmatic.

Do you mean if you are having difficulties exporting quality report in PIX4Dmapper?
Are you able to find the report in the .pdf version in the following path?

Did you click Generate Quality Report?

Reference: Menu Process > Generate Quality Report - PIX4Dmapper

Look forward to your reply if you still need help with this. Feel free to also share some screenshots on the issue you are having.

Best regards,
Rosana (she/her)

Yes it looks like this. It indicates that pdf conversion finished correctly, but in fact it is not created: can not be found in 1_initial\report\project_name_report.pdf and also is greyed out when displaying the quality report in pix4dmapper. The html files are there but the pdf can not be found.

[2023.08.22 02:55:02][ 19%RAM][ 30%CPU][Info]: Running PDF conversion utility: <C:/Program Files/Pix4Dmapper/wkhtmltopdf.exe> …
[2023.08.22 02:55:02][ 19%RAM][ 30%CPU][Info]: … with url <D:/pg2_data/2023-08-18_9d9c9543_HZPC/pix4d/1_initial/report/html/index.html>.
[2023.08.22 02:55:02][ 19%RAM][ 30%CPU][Info]: Running PDF conversion utility: <C:/Program Files/Pix4Dmapper/wkhtmltopdf.exe> …
[2023.08.22 02:55:02][ 19%RAM][ 30%CPU][Info]: … with pdf <D:/pg2_data/2023-08-18_9d9c9543_HZPC/pix4d/1_initial/report/pix4d_report.pdf>.
[2023.08.22 02:55:02][ 19%RAM][ 30%CPU][Info]: … with url <D:/pg2_data/2023-08-18_9d9c9543_HZPC/pix4d/1_initial/report/html/index.html>.
[2023.08.22 02:55:02][ 19%RAM][ 30%CPU][Info]: … with pdf <D:/pg2_data/2023-08-18_9d9c9543_HZPC/pix4d/1_initial/report/pix4d_report.pdf>.
[2023.08.22 02:55:32][ 19%RAM][ 0%CPU][Info]: … finished correctly.
[2023.08.22 02:55:32][ 19%RAM][ 0%CPU][Info]: … finished correctly.
[2023.08.22 02:55:32][ 19%RAM][ 0%CPU][Info]: OS Power Save: Enable
[2023.08.22 02:55:32][ 19%RAM][ 0%CPU][Info]: OS Power Save: Enable
[2023.08.22 02:55:32][ 19%RAM][ 0%CPU][Processing]: Step 3. DSM, Orthomosaic and Index finished.
[2023.08.22 02:55:32][ 19%RAM][ 0%CPU][Processing]: Step 3. DSM, Orthomosaic and Index finished.
Pix4D report not found at D:\pg2_data\2023-08-18_9d9c9543_HZPC\pix4d\1_initial\report\pix4d_report.pdf


Hi @bert ,

Do you happen to use any anti-virus software? Some anti-virus software prevents pdf exports from some software. If you use one, please check that PIX4Dmapper is being whitelisted.

Best regards,
Rosana (she/her)