Support Website Contact Support Blog

Problems with DJI Phantom 4 RTK and PIX 4d

 I just bought a DJI Phantom 4 RTK and I flew my first photogrammety flight and I wanted to try to process it with PIX4d. However, I am having some major problems. When I flew the flight the drone was connected to network RTK and geotagged all of the images in WGS84. Everything looks right in the map that shows where the images were taken. I have a topcon HiperV rover and base station and the surveyor of the job gave me a list of their control points, so I localized to the job and set 11 GCP’s 10 around the perimeter and 1 in the middle. I didn’t do any checkpoints. Please tell me how to upload my quality report because it will show my problems. An additional note is that the jobs horizontal grid is NJ State Plane NAD 1983 and the vertical Datum in NGVD 1929. So I tried in advanced settings to make my output coordinate system NJ state plane nad 1983 as horizontal and arbitrary for vertical, and I also tried arbitrary for both but neither fixed any problems. 

1 Like

Same overhere! DJI recommend proccesing in WGS84 and than transfer. but problems are narrowed down tot 20cm xy en -10cm in z

Try flying with distorsion correction off.

what are you’re problems frank?

@James, you can upload the quality report here and we will have a closer look. Please also specify where in the quality report can we see the problem. 

As for the vertical coordinate system, it is not possible to import vertical coordinate systems. There is, however, a way to introduce a shift in the vertical coordinate system. 

To introduce this offset in the software, you can use the Geoid Height above the Ellipsoid function (which simply introduces a vertical offset). You can find out more here https://vdatum.noaa.gov/docs/datums.html, which also offers a tool to compute this offset depending on your location. 

We also have a video on this topic: Altitude and Vertical Coordinate System - Pix4D Video Academy 14

@Levi

Could you give more information about the project you are processing? What are the coordinates system that you use? Could you please upload the quality report here?

Hi,

More on the optimal workflow when processing DJI Phantom 4 RTK datasets can be found in this community post:
[Desktop] Processing DJI Phantom 4 RTK datasets with Pix4D

Best,

Why Pix4D Cloud doesnt allow the user to select the geoid model to be used?    In my case I want to use EGM08 geoid model instead of EGM96

Hi,

There is one method to customize your project parameters: you need to create a project on Pix4Dmapper Desktop first and choose your desired parameters for step 1, 2 and 3, including the output horizontal and vertical coordinate system. After fine-tuning all the processing options. go on tab Project > Upload Project Files > check option Start Processing and then click on Upload.

Cheers,

Teodora