Support Website Contact Support Blog

Problem with my new Phantom 4 RTK used as PPK

Hi
Thanks in advance for your help.

I bought a new Phantom 4 rtk and I am using it as ppk.
I flew yesterday and had few issues witht the processing.
I attached the reportcut 4 try_report.pdf (2.6 MB)

1 Like

Hi mate.

Good to see GDA in the comments…I’m zone 55 in vic.

Anyway I’m no expert at this (quickly learning) but try these as a short term possible fix…

Hi Mate.
Thanks for that.
I fixed this problem flying the P4RTK with the distortion correction disabled.
Pix4D apply corrections.

Cheers

Rippa

I’m trying to prove you don’t need gcps.

I use Klau also

I’m still having problem with my data.
We flew 5km’s corridor spraying a couple of gcp’s every 300m. I didn’t use them as 3d Gcp but only as check and they all agreed by 20/50 mm in Z value. X,Y spot on.
Yesterday we flew a pit, put 5 gcp’s. One per corner and one in the middle and they all agreed, but this time by 700mm in a value. X,Y spot one
Today we flew a different pit and again 3 gcp’s agreed by 700mm and again X and Y spot on.
Not sure what is happening.
I did not change anything on the processing workflow. Check the pole height on my gps and it was correct… and we used 2 different permanent bases and also 2 different SSM for the static reading with my hemisphere gnss.
I would exclude errors on field work. And so errors on asp suite when processing the ppk… I did check twice…
What is wrong?

2 Likes

Hi Mark, I’d ask that you open a support ticket with Pix4D so we can gather and review quality reports and additional project information. I did not see any GCP’s marked on the quality report provided on Feb 1st. Thanks,
You can follow this link to create a support ticket.
Aaron.

Hi,
did you find the reason why in Z has this error and X, Y is spot on?
I’m having the same problem with a PH4 RTK dataset.

Regards,
Joan

Hola Juan,

Could you please upload your quality report? I am interested into seeing your processing options and the accuracy results.
Could you also describe your workflow?

Thanks.
Great to see you here :wink:
Best

Hi Marco! Nice to see you again!

This project is really interesting (it’s from a costumer). Unfortunately this reports are from the last process and I can’t go nowadays to the office to take the others :confused:

First of all I tried to process all the images together (all are with rtk), but half of them were oriented (in 2 groups) almost 60 degrees with respect to those that were well oriented into the nadir. The orientation of the images was like this —/ (sorry for the graphics).

Then, I group the images by flights and time; I processed by groups and joined them in one project.
I thought that the final project with everything together was fine, however and as you will see in the images that I attach, the projects and the project in general in X and Y are great, but in Z it has a general error around 0’7m with respect to the reference orthometric height. Project 1 (65) curiously has a minor error, around 15cm in Z.

Finally I have been able to correct it with some GCP that have been sent to me, but I am still trying to find some reason why this has happened. It’s not the first time that I have been called due to problems with the Z of the PH4 RTK.

Link to files

More information:

  • GCP and project have the same coordinate system and geoid
  • Flight planning App: Pix4DCapture
  • Flight was above 60m ATO. Then you have big differences of altitude/GSD as you will see into the images

Best regards and take care,
Joan

Hi Joan,

What was the result of the project with all images together?
Which pipelines did you used? Standard or Accurate?
Your graphics are awesome.

That’s usually the recommended workflow.
However I am wondering if using the accurate pipelines with RTK needs this merging step.
I haven’t test it myself, but I would try both methods with the different pipelines.
(In our cases for example I would avoid the alternative pipeline since it is meant for rather flat area (such as a field).)
My recommendations are usually: Test!
Test for lower image scale with different pipelines to see when the calibration is better.
My guess is that the unaccuracy of your models comes from the area where the matching is poor such as here:


This means that the matching is poor and therefore the error on the accuracy might be bigger.
This usually occurs in complex area such as water or forest.
Some processing options however might help.
Enabling the Geometrically Verified Matching could in some cases lead to better matching and hence create a more robust model that is more likely to be well geolocated with the GCPs.
All prior is also a great tool for reducing the relative difference in the camera optimization. It could also help to increase accuracy.
In your two lasts projects your used the Standard pipeline with the same RTK drones. Maybe using the Accurate pipeline could improve them.
Make your tests and let us know what fits better your data sets.

Saludos

1 Like

Hi Marco, hope you are fine.

I have decided to start again using the images with various types of pipelines.

The first is the standard, and as you will see in the report, half of the images are projected as in another plane.

The second processing has been using Geolocation and precise orientation. This pipeline gives good results but nevertheless the model continues with an error of between 0.7m and 1.2m with respect to the GCP.

The third and winner, has been the pipeline using:

  • Geometrically verified match
  • Geolocation and precise orientation
  • Optimization of internal camera parameters: All prior

With the third pipeline, the images are perfectly aligned and in accordance with the GCP :slight_smile:

Reports.zip (3.6 MB)

Have a good day!
Joan

Hi @joan.cano,

Great to see that testing lead to greater results.

Very aesthetic calibration:

The accurate geolocation and orientation pipeline is known to give better results with RTK drones.
Thanks for your feedback.

Best

1 Like

No mate, could not find a good reason for the discrepancies in Z value…
Sometimes I get 0.4 and other 0.02… Not sure. I just put few more GCP’s and fit my project to them.

Try to process with this template - P4RTK.zip (1.8 KB)

It worked for me :slight_smile:

1 Like

Thanks mate,

not sure how can I use the template.
Thanks for the help!

Hi @mapping,

This should help you:

Best