Support Website Contact Support Blog

Poor Results Over Asphalt Tarmacs

I am getting terrible DSM results on asphalt surfaces, with point jumps of over 8m (25’) at times. I have tried all 3 surface smoothing options, increasing the number of matches, using geometrically verified matching, and high resolution 3D textured meshes. Every process version results in a ragged surface that causes wild jumps in the orthomosaic. This only happens on the asphalt surfaces and not in the sagebrush/natural terrain.

Here are some examples:

Ortho Overview

DSM Overview

Ortho Detail

DSM Detail

The DSM and Orthos are clipped in the same area. As you can see in the overview, the pattern of point cloud degradation is limited to the tarmac.

Has anyone else seen this pattern or are there any other settings to try?

Thanks for any help!

Hello Jason,

It is true that tarmac surfaces are more difficult to reconstruct because they are very homogeneous and it is very difficult to extract and match keypoints in different images. What you can do is:

  1. Add some manual tie points in the road area and reoptimize the project to improve the reconstruction.
    This will improve the reconstruction and reduce the noise in the point cloud.

  2. If the point cloud is still noisy and since you are interested in the DSM and Orthomosaic, you can improve the DSM by drawing surfaces on the level of the tarmac that will be considered for the DSM generation and run step 3 again. You can find step by step instructions here: https://support.pix4d.com/hc/en-us/articles/202560449. 

Best regards,