Support Website Contact Support Blog

Point Cloud/DSM very spiky

I have processed a PPK flight using a powered lift aircraft fitted with a modified Sony 5100 (Foxtech Map01 with 16mm Sony lens) and am getting unusual results with the point cloud - it is very spiky/noisy/bumpy in areas which should be very flat/smooth.

The following image illustrates this:

There is nothing in the Quality report to suggest what could be causing this. Some settings we have experimented with include

  • Image scale - Half image size
  • Multiscale - ticked
  • Point Density - Optimal and Low
  • Minimum number of matches - 3 and 4
  • processing using non-geotagged and geotagged imagery

Thinking it is an image matching issue, perhaps something happening with geotagging?

We have done other projects using the same equipment and workflows and have not experienced this issue before… any help would be much appreciated!

Try increasing minimum number of matches to 6. Will result in less points, but will be cleaner. It may help remove some of the noise you are seeing.

What was the relative difference between internal and optimized camera parameters in your quality report? Can you post it?

From what I can tell, your images look crisp and that area looks like it has plenty of image content and no shadows. Not the type of site I’d expect a lot of noise like that in the DSM.

What drone? I have noticed something similar when I was testing out the Mavic 2 Pro side by side with the Phantom 4 Pro and eBee + Soda for about a month. The quality of the DSM with the Mavic wasn’t up to par.

Thanks for the suggestion Andrew - I have tested this on a small sample. There were less points and it was a bit cleaner as you predicted but still the very flat surfaces are far more bumpy than they should be on a site like this…

Hi Derrick. Here is a copy of the quality report- pix4d_report_forum.pdf (2.7 MB) (the uncalibrated area was to be expected as it was a steep ridge).

My thoughts exactly - images are clear, lighting conditions decent and nothing complex about the terrain so it is a bit of a mystery. Identical workflow and equipment used on another site in the area came out better.

Drone is a Foxtech Nimbus VTOL 2 with a modified Sony 5100 (Foxtech Map01 with 16mm Sony lens).

1 Like

Thanks Patrick.
Nothing in there jumps out at me as a problem, but you’re also using some settings that I have rarely used and don’t really have a good baseline as to what’s normal. Most apparent to me:

  1. Noise filtering & surface smoothing is turned off (That would be my guess as the problem, if you hadn’t already said that these are your normal workflows, which I assume includes processing settings)

  2. Point density is set to “low”. Maybe Pix4d support can confirm this, but I think that their filtering will reduce points in flat areas and increase them for Z deviations. If that’s true, I would think that this setting combined with #1 would be the cause of what you’re seeing. Again, that would be assuming that these are not your normal processing settings.

  3. Your DSM and ortho resolution is being resampled to 5cm/pixel from your acquisition GSD of 3.31cm. I normally export my results out of Pix4d at the max resolution/acquisition resolution and do my resampling in GIS afterwards. I don’t know that Pix4d handles this any differently. Just mentioning it because That’s not the normal workflow I use.

  4. Your image coordinate system is WGS84, instead of WGS84 (EGM 96 Geoid) that I see in 99% of people’s quality reports. Plenty of reasons why this could be correct for you and I don’t see how this would cause a problem, but again…abnormal for what I’ve seen.

#1 & #2 are the only guesses I have that would really cause what you’re seeing, but only if these aren’t your normal settings that you’ve used in the past without issue. Otherwise, I’m at a loss.

Much appreciated Derrick.

Most of those settings were chosen based on matching the settings of a neighbouring area which was very large scale and we were looking to reduce processing time where possible.

I’m going to run a few more tests adjusting the settings you mention and see if anything improves the smoothness. Processing time not such a factor with this size site so can revert to normal workflow and compare results

Will report back with findings! Many thanks for the advice.

1 Like

Hey Patrick, just curious what your findings were after re-processing?

Hi Derrick

Unfortunately there has been no major improvement in re-processing with the following adjustments:

  1. Noise filtering & surface smoothing on (this is only in Step 3 so assuming it wouldn’t affect the Step 2 Point Cloud outputs?)
  2. Point density - optimal (obviously a lot more points which in some ways is worse as there are even more outliers). Also tried with 4 and 6 minimum matches.
  3. DSM & Ortho back at default 3.31cm (no noticeable difference, often only generate ortho only and do the surface models in other software after classifying point cloud)
  4. I can’t see any option for WGS84 (EGM 96 Geoid) in the image coordinate system - only WGS84?

Even the DSM generated out of pix4d is inconsistent/variable where very flat surfaces exist:

When comparing the same site with images taken with a Phantom4 RTK, we noticed that the exposure was quite different, showing more clarity and detail in the P4 imagery. My next test will be to adjust brightness/exposure of photos in one of the flights with Sony camera to see if I can improve the clarity which may improve photo matching…?

Here is a direct comparison of the P4 surface (much smoother) on the left of the road, and the VTOL on the right (much noisier).

Interestingly the quality report says, that no camera optimization has occured. Although it should since it was ticked to “all” in the processing options. Am i missing something or is that weird?

I would try to reoptimize the project with the following processing options set to “Internal Parameters Optimization: All prior” and “Use Geometrically Verified Matching: no”. My impression is also that the multiscale Image Scale benefits some more noise in the pointcloud. But this could also be very dependent from the actual project.

Greetings

Additionally - what software did you use to display the DSMs? Maybe its caused due to different (natural neighbor, bilinear etc.) sampling/display settings in the DSM properties.

Is there standing water on the ground? That would certainly cause issues in those locations. But wouldn’t explain dry areas.

Thanks Till - I reprocessed with Internal Parameters set to All Prior and Geometrically Verified matching off and multiscale off too.

This resulted in less points in the pointcloud but the flat areas still seem quite noisy, although probably an improvement. Image below shows original surface top half, and re-processed surface bottom half. There is obviously more interpolation but even in the areas of dense points, it’s still not as flat as you would expect…

Surfaces are generated in GlobalMapper. I don’t believe it could be sampling settings as the P4 dataset was compared in exactly the same way and the difference is very obvious.

Beginning to think it may be something related to the lens/photo quality - perhaps affected by dust build up inside the lens…or pixel resolution.

Hi Andrew
True… but no, there is no standing water here - it is a very dry site. There are some shiny effects in places, which creates a bit of glare - but you still wouldn’t expect the inconsistencies in the surface models… will try adjust exposure of images and see if that has any effect.

The only other thing I can think of is the imagery itself. What was your overlap (front and side)? Were the images property exposed and in-focus? You results look like poor tie point matches, which would result in inconsistent elevations.

If you take a look at the quality report, overlap and number of automatic tie points seem quite ok. Nonetheless, the orthomosaic preview looks a bit striped. Maybe the side overlap is not sufficient enough. I also noticed that you @patrick2 set the minimum number of matches to 3. May this is a bit low.

These are all just guesses.

Overlap was 70/70. The images seem to be in focus but I will test with adjusted exposure settings - they do look okay, although brighter than the P4 equivalents.

Thanks Till, overlap was 70/70 but perhaps we should increase this.
I did try setting minimum number of matches to 4 and 6 which had minimal effect…

If the images are significantly over exposed, that could reduce texture and produce problems with automatic tie points.