Support Website Contact Support Blog

Pix4Dmapper - Large agriculture and vegetation, 3 differents flights, very hard to process


I’m having an hard time to properly process 3 differents flights in one project. The object of the survey is a large and mostly flat agriculture land with some sectors covered in vegetation. We perform 3 differents flights for about 900 photos, 70 mt altitude with an high overlap, so I tried the following:

  • Process the whole data as one project and “standard” settings, resulting in an inclined surface, several sectors empty and several errors reported in the process
  • Process 3 sectors separately, trying either the standard settings, either the following the “alternative” calibration method with 1/2 keypoint image scale
  • Merge the 3 sectors eventually

I’ve already tried to follow the advices found in these articles

results remains very poor Here’s my process report

Also, here’s some screenshots of the results… even if the altitude was always the same, it looks like the 3 flights has been placed at differents altitudes…

Maybe somebody could provide some advice?


Hi Marie-Claude

Seems you are flying with Mavic Pro. Here’s the main problem with your project.

You should check “all prioir” in Camera Optimization

And since Mavic Pro has rolling shutter you should change shuttero model to “rolling shutter”

Give it a go with these settings

EDIT:  If you can share the data set I could take a look at it

Hi @Jaakko, thanks for your reply

I’ve tried with those settings, the results are still unsitisfying

Here’s the new report

With sharing the dataset, you mean the pictures?


By dataset I mean the pictures. I can try to process you project on my computer and see if I get better results.

I don’t honestly believe it’s a computer issue, I’ve already tried to have it processed on a different desktop. Also, it’s a several GB data-set. I can share a part of it, maybe you could have a look if there’s a problem with the pictures…

I’ve also proceed to re-optimized the camera followingthesearticles, the final report has no issue alert

but the results remained unsatisfying

It really looks like there’s a specific problem with the drone altitude detected by the software

Here’s the last report

Here’s some images coming from the different flights


It’s not computer related issue. There is just so many things you need to change to process that project successfully.

There’s still 7 different blocks which means that there is some kind of misalignment. One is obviously here:

If you don’t want to share the whole dataset then you should manually change the altitude in exif-data to match correct altitude. Next you should use manual tie points in common area between flights.

I looked at the pictures in the link you provided and in my opinion overlap wasn’t sufficient. Flight number 3 seems to be out of focus/blurry.

I would go out in the field and fly the same area again if possible. This time a little higher altitude and with better overlap.

Hi Jaakko, we arrived at the same conclusion, today I manually changed the EXIF altitude (apparently it’s a common issue with DJI drones) and fix the assemble issue

Now, regarding the several uncalibrated pictures, I understand that the area covered in vegetation (on the right in the image above) might be tough to process.

I doesn’t look like the flight 3 is out of focus, not more than the others however

Also, the overlap was pretty high (80-85%) and the altitude 75 mt. Sadly the ground it’s now covered in snow, so we would have to wait to perform the survey again.

I think it might help to process the project separately (3 parts) using alternative calibration method and 1/2 image scale size. Then, I’ll have to manually calibrate the remaining pictures. What do you think?


I doubt that you can manually calibrate that amount of pictures. My advice is to wait snow to melt and fly again and you can always try different settings while you wait :slight_smile:

I will, thanks again for the support… hopefully we will have a short winter!