Support Website Contact Support Blog

Pix4Dcapture + M200 suddenly won't launch due to DJI error

I’ve been using Pix4D capture with our DJI M200 v1 and MicaSense RedEdge-MX for about a year now. Early this year we upgraded to the MicaSense Dual Camera system. I’ve successfully flown 4 missions this year with this equipment, all firmware is up to date. Last week I attempted to fly a mission and Pix4Dcapture gave me an error message and told me to check the DJI Go 4 software for details. DJI Go 4 shows a camera error (expected as DJI Go 4 doesn’t “see” the RedEdge cameras but still normally allows flight) and also an aircraft encoder error. These are the only errors that I see but I can no longer launch the mission from Pix4Dcapture. I contacted MicaSense and they suggested trying Atlas Flight for mission planning since it also uses the DJI SDK however it is iOS only and I only have an Android device. If I install the standard RGB (Zenmuse X5S) camera, there are no errors and I can complete the flight without issue.
Does anyone have any ideas why this is suddenly happening? I really don’t understand why I could fly two weeks ago with the exact same configuration and software but could not fly a week later with no software, firmware or hardware changes.
I have tried restarting all the equipment, I have reformatted the microSD card in the UAV using the DJI Go 4 app. Nothing has resolved the issue.

Hello @SoilTech,

The Pix4Dcapture doesn’t support the automatic triggering of the MicaSense cameras. If a Non-DJI camera is mounted on DJI drones, Pix4Dcapture will not be able to trigger the camera. Making it work will rely on the fact that a timelapse can be set in this custom camera. A specific functionality has been developed on iOS to keep the right overlap up to the camera specifications. More information here.

I would also recommend you to go through our support article on Which image acquisition app can I use with Pix4D’s software?.

I would also suggest you to wait to see if anyone had the same issue and the workflow that has been using to resolve it.

Regards,

Hello,

I realize that Pix4DCapture does not support automatic triggering of the MicaSense camera. I have flown plenty of missions with the MicaSense cameras and Pix4Dcapture using the triggering features and appropriate overlap of the MicaSense utilities. My issue is that the UAV will no longer launch a mission after uploading. I have a screenshot to show the messages received. The UAV microSD card (which is actually not used during the mission) has been reformatted using the DJI Go 4 app and the MicaSense camera SD card has been formatted using the MicaSense utility. I have tried this with 4 different SD cards, all of which have worked fine for all my previous missions. This issue only occurs with the MicaSense cameras installed, I do not have any issues with the Zenmuse X5S camera installed. I’m not sure what may have changed from one week to the next but something is obviously different with respect to either the DJI SDK or Pix4Dcapture. I did not execute any firmware updates between the previous successful mission and the first failed mission. I’m just trying to figure out why the exact same equipment and software was successful for months before and now suddenly fails.

I have also tried the entire process using Atlas Flight on an iOS device instead of Pix4Dcapture on my Android device and again, the UAV would not launch but I did not receive any error messages.

Regards,

SoilTech​​​​​