Pix4D Matic does not apply geoids

Does anyone know why despite applying a geode when processing with Pix4D Matic, the elevation is processed without taking it into account so that an elevation is still obtained based on the ellipsoid and not based on the geoid?

I am processing images from a Mavic 3M, specifically RGB images from a RTK flight.


Hi @joan,

Thank you for your message.

Can you please share the quality report with us? Which geoid model do you want to be applied in your results? Are you using Ground Control Points (GCPs)? Have you tried to process selecting the ellipsoid and compare the results?


Hi Daniele,
sure, please find it attached. I want to apply the REDNAP EGM08.
In this case I’m not using GCP.
Yes I tried to process selecting the ellipsoid, trying to assign an offset… and nothing.

To give you more information, I see that Pix4DMatic recognizes drone images with the image coordinate reference system WGS 84 + EGM96 height - EPSG:4326+5773

I don’t understand why it is so when the flights are made in WGS84 (besides, if you process the same images in Pix4D Mapper it only recognizes them as WGS84).


cita_rgb-quality_report.pdf (21.2 KB)

(message removed because it contained outdated information)

Hi @joan,

After further review of the quality report, it seems that the “Image coordinate reference system” fell back to WGS 84 + EGM96 height instead of keeping WGS 84 + Ellipsoidal height used generally for RTK drones.

Since PIX4Dmatic 1.46.0, it is possible to manually select the image coordinate reference system.

Please proceed as follows:

  1. Click on the pencil icon to open the “Image coordinate reference system picker”
  2. Select Ellipsoidal height over the WGS 84 ellipsoid as vertical CRS
  3. Calibrate the project again

Please let me know how it goes

Fantastic! It seems that the processing is correct.
Thank u very much Daniele!


1 Like

Happy to hear that.
Thank you for the feedback :slight_smile:

Happy mapping!