Pix4D mapper not using dedicated graphics

Hi all,

I am finding that Pix4D mapper is not using the dedicated GPU in my laptop, but instead is using the CPU graphics. See images below.


In NVIDIA control panel is have set global presets to High-performance NVIDIA processor, and also set Pix4D in program settings. See below.



I can also see in the log output that it is detected as a CUDA capable device.

Also detected in Resourses and notifications


Any help would be appreciated.

This is happening on two different laptops, one with a RTX A3000 and the other with a RTX A2000

Hi gis6,

You need to also adjust the Windows graphics settings.

Select the PIX4D executable file for the selected program, select Options, and then select High performance.