Support Website Contact Support Blog

Pix4D Desktop 3.2.23 - Feedback and Experience

Hello everyone!

We are happy to announce that the stable 3.2.23 version has been released.

What is new in this version:

  • LOD mesh generation and export in OSGB and SLPK format for faster loading on web viewers
  • faster upload up to 10x
  • new feature in the Quality Report 
  • Generate Contour Lines from the Process Menu available for both DSM and DTM 
  • Russian language
  • many improvements and bug fixes

You can download it from here: https://cloud.pix4d.com/download/.
and find the detailed release notes here: 115005738363.

Feel free to share your experience by posting a comment below.
We are looking forward to your feedback!

Happy Processing!

Pix4D Support Team

Bug:

When creating a new project the project name does not accept special characters - which is fine and also mentioned in the support notes https://support.pix4d.com/hc/en-us/articles/115002463363-How-to-create-a-project-in-Pix4Dmodel.

However, it seem to accept german special characters such as ä ö ü (I only tried ü).

Unfortunately, when saving that project (e.g. after calculating everything) you can’t re-open it later due to the special characters in the title. When trying to load it an error message pops up (didn’t save it, sorry).

Maybe consider prohibiting the usage of ä ö ü in the project title, too? 

1 Like

We were able to reproduce this. This is indeed not a very user friendly behavior. We have opened a bug report and will be working on fixing this. Thank you for bringing this to our attention. 

Bug (?):

Mosaic Editor not working.

Workflow: Step 1 - Add GCPs - Reoptimize.
Settings for Step 2:
Point cloud: Minimum Number of Matches: 4, rest default
3D Textured Mesh: Not selected (Do not generate)

Settings for Step 3:
Resolution: Automatic
Orthomosaic: GeoTIFF, Merge Tiles, Google Maps Tiles and KML. (The rest is unselected.)
No Additional Outputs.

Start Processing Step 2 + 3.

The project is processed and finished. The orthophoto and tiles are present in the 3_dsm_orth folder. However, in Pix4Dmapper the Ortho Mosaic button is greyed out and can’t be selected. The log file reports some errors:

Warning w9020: GDAL error <4> `C:/Users/xxx/ProjectName/ProjectName/ProjectName/3_dsm_ortho/1_dsm/tiles/ProjectName_dsm.tif’ does not exist in the file system, and is not recognized as a supported dataset name.

I had this problem in a couple of projects until I re-activated the creation of the DSM. The mosaic editor worked then. Haven’t tried whether the problem re-occures when de-selecting DSM again. 

 

 

 

The DSM must be generated (in the processing options) for the Mosaic editor to be available (it is not necessary for the tiles to be merged, but the checkbox next to DSM must be ticked here

https://support.pix4d.com/hc/en-us/articles/202557769#label1