Support Website Contact Support Blog

Pix4D and DJI Matrice 210 X5S Problem

Dear Support. 

Is there any problems with M210 and X5S with mapping or Im doing something wrong?
Im completely new and I made some missions at 40m AGL. There is some problems with camera optimalization

Tried 2 difirent X5S cameras with DJI lens and difirent drones with same results. Of course everything calibrated and updated.

There is no problems with X4S camera.

What is more, sometimes Pix4D prompting that two cameras are connected but there is only X5S connected!

Any ideas?
PIX4D reports and photos: https://drive.google.com/drive/folders/1jgjmZDngPmf_edqv0NuvO0PgdeSW3dkv?usp=sharing

Hi Lucas,

Welcome to the Pix4D community and thank you for sharing your experience here.

In a first time I would suggest you go through all the steps of our basic checks and troubleshooting article as your configuration is supported by our application if you look at our supported drone and camera webpage. If correctly followed, it will enable to solve most of the issues encountered by users.

When selecting the X5S camera in Pix4Dcapture, by default, it will be the 15mm focal length. All the calculations in order to respect the settings (overlap, flight height) you have defined will be done using this focal length.
Then, as a consequence, if you are using lenses with different focal length, the results will be impacted and as the overlap set in Pix4Dcapture will not be valid anymore, it may lead to processing/reconstruction fails/issues.

Best,

Dear Gaël,

I selected X5S Camera in Pix4D Capture with 15mm focal lenght and this photos was made with X5S and 15mm DJI lens.
Can you check this photos and verify whats wrong with them?

Hi Lucas,

Can you specify your statement here: “sometimes Pix4D prompting that two cameras are connected but there is only X5S connected!”
Are you talking about Pix4Dcapture or Pix4Dmapper? If Pix4Dcapture, what cameras are recognized? Normally selecting the X5S in the settings should not induce any issues.
In all the case, I invite you to read the basic checks and troubleshooting article I mentioned in my previous answer.

Did you experience an unexpected behavior during your flight or anything that was not following the normal workflow when it comes to image acquisition (flight path…)

Also in your case, I would suggest processing your dataset using the following options:

  • In Processing Options --> tick Advanced (see screenshot) --> 1. Initial Processing --> Calibration --> Camera optimization --> Internal  Parameters Optimization --> select All Prior
  • If not ok, in General --> Keypoint Image Scale --> **Select Custom and 1/2 (half image size)

**
Let me know if it solves the issue,
Best,

Thank you Gaël

I just set Internal  Parameters Optimization -->  select All Prior and seems to be better but I dont know why Pix4D recognized two Zenmuse X5S connected to Matrice M210. It was set to X5S camera during flight in Pix4D Capture.

 

Reports: https://drive.google.com/drive/u/1/folders/1jgjmZDngPmf_edqv0NuvO0PgdeSW3dkv

Hello Lucas,

I suggest you to read the answers of our technical support in this thread about the fact you mentioned.

Sometimes, the camera serial number written in the image exif tags changes (it happens randomly and we did not find the reason yet) and the software will create several camera models according to that. It may also happen when exterior conditions (weather, exposure) vary greatly during the flight.

Best,

Thank you. Seems everything is solved.

 

Hi Gaël.

Can you check my project and tell me why terrain is rounded?

https://cloud.pix4d.com/pro/project/439587?shareToken=b2c67b6b-5294-40f9-9581-a210b2fde23a

This project was made with Zenmuse X5S camera.

 

There is no such problems with X4S camera :frowning:

Hi Lucas, 

The camera optimization process failed. There is 19.51% relative difference between initial and optimized internal camera parameters. I would recommend you to use “All Prior” option for Internal Parameters Optimization during Initial processing as shown in the figure below.

To do so, create the project in the desktop version, set the desired settings and then upload it to the cloud. 

How to upload project files from Desktop to Cloud

  

I tried that way Kapil but now pix4d cloud cant generate 3D Textured mesh in my project :frowning:

https://cloud.pix4d.com/pro/project/440102/map?shareToken=7ae1b255-6f07-46ff-a355-da5922c5970c

Hi Lucas, 

You haven’t selected any output for your project that is why you are not able to see any results. To enable it, follow the article Output is not displayed / feature is missing in the cloud.

Meh. Trial version don’t support 3D textured mesh LAS export to cloud in desktop mode :frowning:

Hi Lucas, 

You should be able to do that using the trial version. I see you are logged in using the “discovery mode” that is why you were unable to access those feature. So, I would recommend you to log out of the software and login back using available license (trial version). 
How to log out Pix4Dmapper Desktop

 

OK I just made new project in colud.

“All prior” camera calibration settings was checked in pix4D pc version.

Terrain still looks rounded like a ball :frowning:

 

https://cloud.pix4d.com/pro/project/440708?shareToken=a37dc371-3bb2-4acd-9b6c-9709ca4eeeaf

 

Any ideas?

Hi Lucas, 

The result looks better than the previous. The effect might be due to the optimization of the rolling shutter camera. If you are more concerned about the accuracy, I would recommend using GCPs (Ground Control Points).