Support Website Contact Support Blog

Pix 4Dmapper not recognizing Nvidia K4200 Cuda

I’m using a trial of pix 4d.  I have a test project of 7265 images. I’m using the 3d model default setting to produce orthimage and topo data.  My project is only 30% of step one, after running for 16 hours.  I was trying to figure out why, under notifications, pix4d doesn’t recognize my Nvidia k4200.  I have the latest drivers installed from nvidia site. I have Nvidia desktop parameter set to 3d - gaming.  What am I missing?  See images below.

pix4Dmapper 4,2,27

Computer:

Dell precision 5810, xeon cpu E5-1680 v3 @ 3.2ghz, 32 gb ram, k4200 cadrd, SSD 980gb

Thanks for your help!

Hey Mike,

You would be able to confirm if your GPU is enabled. Just go to processing options then resources and it should show up there if your GPU is enabled or not. Please feel free to take a look the following link as well:

https://support.pix4d.com/hc/en-us/articles/202560199

Selim - Thanks for the response. I have read that support article but as you can see from the images I posted, the Nvidia card is not being recognized by pix4dMapper.  See image above.  If there is a separate box to enable please direct me as to where that would be so Pix4DMapper will recognize that it is available.

Hey Mike, 

Yeah it weird that Pix4D doesn’t recognize it. Normally you should have an option whether you want it enabled or not in that same box. I am not sure, I would send a ticket to customer support, they may be able to help you out.

And honestly that is just all the wrong hardware for Pix4D, a desktop/gaming machine is way faster and produces more accurate results than any server system. I have used multiple server configurations and quite frankly the accuracy and performance are laughable…but my testing was almost a year ago so the latest Pix4D could be better.

Thanks Adam, It is a multi-purpose workstation, C3D, Laser Scanning.  It has preformed better than a previousl i7 machine with a GForce gaming card. The current machine has let me process laser scan info and continue to draw in C3D.  The i7 machine seemed to stall or crash.  It does seem to take a long time to process images.  I have a 7200 image project that I broke into 1500 image groups and it is taking 16-18 hours to complete per section. That is why I was hoping that recognizing the CUDA’s would help.

I still have not heard back from Support ticket.  Thanks again!

Hello Mike,

Did you try maybe to uninstall and reinstall the GPU drivers?

Regards,