Support Website Contact Support Blog

Phantom 4 Pro +

Hello,

same Problem here. Pix4d and Ctrl+Dji installed but no Connection to the drone.

It may be beacuse DJI GO is the default app for the 4pro+ Remote Control. When connecting the Drone and RC via microUSB the app “sees” the drone but you can’t fly like that.

So far neither DJI nor Pix4D support could help with a solution. Has anybody managed to solve the issue?

Plan B is to exchange the RC for the RC of the 4pro and get a tablet/smartphone.

Cheers,

Francesco

Same issue here, looks to me that pix4d, just need to update the app to account for the phantom 4pro plus  built-in crystal sky tablet

Same issue here too, Pix4d and Ctrl+Dji installed, pix4d is working, I can see map, i can see the position of the drone, set grid but cannot connect to the drone.

Has DJI and Pix4d figured out how to work out the issue.  Just ordered the Pro+ now thinking about returning it.  I don’t want to use another app but can you, to get your flight plan, Pictures, and Geo Tags?

 

I have a couple Phantom 4 Controllers, can I use those with the Phantom 4 Pro Plus to use my IOS and Pix4d App?

Has anyone here tried to stop the DJI processes in the system settings -> apps menu (on the RC), and then run the ctrl+dji app? I have a pro+ myself, but haven’t tried adding the apps to the RC just yet. Would like for this to work, without having to buy a new RC…

Hello Guys,

I have buy a new phantom 4 pro plus too and I would want run pix4dcapture in it.

 

I had this same problem for weeks, but it is fixed following the 5 steps :

  1. Update your phantom 4 to the newest version (You will can install 3rd apps);

  2. Download the pix4dcapture APK and Ctrl DJI APK to a micro SD card;

  3. Insert the micro SD card in the RC;

  4. Install both the pix4dcapture APK and Ctrl DJI APK apps and run them;

  5. Use the USB cable by itself how show in this video ( at time 2:27 ): https://www.youtube.com/watch?v=5UCF5PFb0YM

I don’t know why, but its works sussesfull in my Phantom 4 pro+

Please, comment if it worked for you too.

Bye

3 Likes

I tried your procedure and worked perfectly thank you very much!

Hi, i have had the same issue; the “Topoterra Ltda” solution it’s very good !!!

Hello everybody - I´ve a remark according the way described to get pix4d running on the p4p+ rc in built screen… I accomplished the entire procedure and the pix4d app seems to be up and running (the rc is connect to the drone etc.). When i try to start a grid or polygon mission, all of the dependencies (home point, gps signal etc…) are checked (green symbol) and I theoretically have to press the start button for 3 seconds… So far so good – if I try to initiate the take-off process, the drone simply does NOTHING… After approx. 10 sec. the rc provides a single bleep signal and on the screen appears a green box stating " landed".

Did somebody face similar issues – I´m trying to fix this issue for over a week now, because I bought this drone for work and I badly need the function of preset-waypoint-flying for photogrammetry tasks - otherwise the drone is +/- useless for me and my organisation.

Thank you in advance!

@michael, for an optimal experience with Pix4Dcapture, we recommend proceeding with basic checks. This article helps users to troubleshoot app issues in most cases. If you have any doubts about the workflow with the app, you can refer to our getting started.

Before using the drone check if it can be flown with the manufacturer app without any issues and that all the sensors, e.g. compass, are calibrated. It is also highly recommended making sure that the settings in the DJI GO app are not too restrictive, e.g. maximum altitude is not lower than the altitude set for the Pix4D mission and that beginner mode is disabled.

@Blaž (Pix4D) -

thanxalot for your quick reply - I´ll definitely check the settings once more… In fact, I already accomplished some test flights using the dji4go app and everything works as it should (including the camera system). Beginner mode is disabled as well…

As previously described  - all prior settings in the pix4d app are seemingly ok, but I´m not being able to take off, which is also true for the freeflight mode within pix4d. I gonna check settings (within the dji app as well as within the pix4d app) once again.

However, thanks for your effort!

 

 

It happens to me sometimes. Restarting the controller and the drone usually does the trick. Try to update firmwares too. 

Hello  everybody , I just went through the advices provided for me during the last couple of hours… However, I´ve been rather sceptical because I already went through all the settings-checks more than once before… Sadly, I couldn´t get rid of the problem that the drone still won´t take off using pix4d (but it does when using the - for me -> “useless” dji4go app). I´ve taken some screenshots for further evidence:


As you can see there aren´t any issues noticable that the drone won´t function… Please - any clues anyone… I´m becoming more and more desparate…

Hi Michael,

Are you updated with the latest drone firmware and the latest version of Pix4Dcapture and ctrl+DJI?
Also be sure that DJI GO 4 or any drone-related app is not running in the background when using Pix4Dcapture. Following this procedure might also solve a potential conflict between apps. (if it can be apply to P4P+)

When restarting from scratch make sure to switch on the drone, then the RC and then opening ctrl+DJI and Pix4Dcapture.

Also, a suggestion would be to try to takeoff manually and then running Pix4Dcapture to see if it solves the issue. 

If all the suggestions above do not work, please try to reinstall ctrl+DJI and Pix4Dcapture from scratch.

Any workarounds from the users who bumped into that issue would be appreciated.

Best,

Hi all.  Can anyone point me to where I could fine the procedure to download APK files to an SD card.  I want to try Topoterra’s solution but have never downloaded raw APK files for apps.  Thanks all.

Hi Vince,

We are currently working on it. In the future, we will put the latest APKs online at a defined location, so that they are easy to get for users. A link to download them will be accessible from our support website. 

Best,

Downoad the App in APKpure.com. You have to download 2 apps, Pix4d capture and ctrl+DJI. Copy the downloaded files in the SD card, insert it into the controller, browse for the File then install.

1 Like

Hello everyone,

But how to you install the apk files in the drone, i am using my phone as display and i don’t have a slot for sd card on the controller either.

Hi everyone, i have already install litchi apk in my phantom 4 pro + now i want to know how i can use the litch app and pix4d capture to map

Stephan,

You only need to download the APK file when you are using the PHantom 4 Pro PLus controller. 

In your case, you are using the Regular Phantom 4 Pro controller. DOwnload the PIX4D capture and CTRL+ DJI in the google playstore.