Output Coordinate System for GCP's

I’m wanting to create a new dataset with some GCP’s for a project in California. The Output Coordinate System is defaulting to EPSG:32611 - WGS 84 / UTM zone 11N. I’ve tried uploading the Easting and Northing and Elevation. I’ve tried uploading the Lattitude and Longitute as Decimals. I’m able to upload. But then when I click on the preview map it seems to think we are somewhere in the middle of the Pacific Ocean. I tried to process the project and it processed but it rejected by GCP measurements. Not sure what I’m doing wrong. I reached out to customer support but they have been slow to respond and not very helpful so far.

Hello David,

I will try to go step by step.

  1. Create a project and upload the images
  2. Select processing options
  3. Upload the GCP file → It has to be in the format described here: https://support.pix4d.com/hc/en-us/articles/360035734371-AutoGCPs-detection-functionality-PIX4Dcloud-Advanced#uploadGCPfile
  4. Define the coordinate system of the GCPs. You can either search for it or drag and drop a WKT file with the defintion. This is mandatory and you have to know this information or if the GCP file is coming from a third person, you have to ask which one it is.
  5. Check the GCPs are correct → Go to the map view and see if they are located in the right position. If the background is blue, it means that they are in the middle of the ocean. An example of properly located GCPs is below:
  6. Click on process

Please take into account that we only support the targets described here and there are some other conditions to fullfill: https://support.pix4d.com/hc/en-us/articles/360035734371-AutoGCPs-detection-functionality-PIX4Dcloud-Advanced#requirements

Thank you very much.

Our surveyor submitted the same locations to us 3 different ways.

I’ve tried each of these different sets of data with 4 different coordinate systems.

None of them seem to work properly.

Shouldn’t “EPSG:32611 - WGS 84 / UTM zone 11N” work with the Latitude and Longitude in decimal format?

Shouldn’t Local work with “EPSG:2229 - NAD83 / California zone 5 (ftUS)”

Below is an image of the data I have to work with.

If we plug these into google earth they show as the correct locations.

Hi again,

The coordinates of the GCPs have to be in a projected coordinate system, not latitude/longitude.
You have to import the first set of coordinates that you have but it is necessary to know what the local system is. If it is EPSG:2229 - NAD83 / California zone 5 (ftUS), then it should work.
In the step 4 above, please select the coordinate system first and then go to “See and edit control points” to check the points on the map for verification.


This once a day emailed response is fairly frustrating.

To be honest I’m thinking of switching to drone deploy at this point.

What I’m asking is a very specific question that for some reason you are unable to answer.

I sent you 3 different versions of our GCP coordinates.

A local system with easting and northing.

WGS 84 with latitude and longitude

WGS 84 with decimals.

We know what we think each of them should be called.

For some reason your software think we are located in the middle of the Pacific Ocean so something is obviously not correct.

I’m asking you to look oat our 3 different versions of our GCP coordinates and for you to tell me what “Coordinate System” we need to input into your software to get to work properly.

I would think WGS84 decimals is the best one to use and that coordinate system “EPSG:32611 - WGS 84 / UTM zone 11N” should work.

But it’s not working. So is it a glitch in your software or what specifically to I need to do to get this to work?

Thank you

David Delis



Famoso Nut Company, LLC

32331 Famoso Woody Rd

Mc Farland, CA 93250-9771

(Attachment Famoso Facility Co-ordinate list.xlsx is missing)

Hello David,

The coordinates have to be projected in meters or feet, they cannot be angles so the last two set of points will not work. The reason is that the coordinate system of the GCPs will define the coordinate system of the final result and it (the result) can not be in a geographic coordinate system (lat,long)

I have created myself a file with the first point (1645762.636, 767004.259 ,451.8) and I have imported in PIX4Dlcoud. I have selected both EPSG:32611 - WGS 84 / UTM zone 11N and EPSG:2229 - NAD83 / California zone 5 (ftUS). In both cases, the point is in the middle of the ocean according to PIX4D cloud

Then I have done another check, I have used this online converter to check your coordinates (there are others online) (Transform coordinates - GPS online converter)

If those coordinates are in EPSG:2229 - NAD83 / California zone 5 (ftUS):

That lat,long are in the middle of the ocean.

If your coordinates are in EPSG:32611 - WGS 84 / UTM zone 11N:

Those coordinates are also in the middle of the ocean (in a different place)

I cannot guess in which coordinate system the coordinates are.

What you have to do is to know what is the coordinate system in which you want to get the final result, and then ask the GCPs in that coordinate system or convert them to that coordinate system if they are given to you in WGS84 before importing them in PIX4Dcloud.

I hope this helps.

If you can give me a list of all of the possible coordinate systems I will go through and try each one.


I got it to work by just randomly trying every GCP coordinate system with the word California in it.

Apparently this is what we are. EPSG:26745 - NAD27 / California zone V

(Attachment Famoso GCP Local.csv is missing)

Can you give me a credit of 2,409 images so that I can reprocess the project that I processed and the GCP’s failed?