Support Website Contact Support Blog

GCP Data Entry not Allowing Lat and Long

Dear Sirs,

 

I am trying to enter some GCPs to evaluate your software and for some reason, the GCP will only allow me to enter an X and Y and not enter a Lat or Long. If you look at your various support pages, it allows Lat and Long to be entered and is labelled accordingly. This is proving to be quite a challenge. I assume therefore when I go to process, this is why the error “GCP and image geolocation do not lie in the same area…” comes up. Any help would be greatly appreciated.

 

I have now selected WGS84 mercator and it allows me to enter a Lat and Long but before processing I am still getting the same error message.

Was 3D control selected?

I selected 2D as I only had a Lat and Long and not an altitude for the GCPs. Is this what you mean or is there somewhere else for that setting please? I followed what I thought were the instructions from the Pix4D support information.

Sorry, misunderstood, thought you are questioning the Z axes.

No sorry. It is more about telling the software if the GCP is a Lat/Long or an Z,Y coordinate. It seems to have not worked so far and I cannot find where to make the necessary changes. Hopefully Pix4D support will pick up on this thread… Cheers for your help anyway.

 Can you verify what coordinate system the GPC where captured in?

WGS84 using a Garmin GPS unit. 

 

Using a Garmin GPS does not provide coordinate location accurate enough to be used for Ground Control Points in Pix4D.  You are introducing more uncertainty than you are removing.  You need to use Survey Accurate GPS for GCP data collection.

 

Hi Aaron, Thanks for the information and noted your concern. If I can use a Survey Accurate GPS, would the format generated be suitable for input into Pix4D from the point of type, e.g. WGS84 UTM30N? I guess my original question is how do I change the input format when trying to put a GCP into a project? Can you give a steer on this at all as you seem experienced as a trainer? 

Many thanks

HI Michael,

It sounds like the GCP coordinate system may not have been properly defined.  Pix4D offers a support article How to include GCPs in the Project that you may find helpful in addition to another calledHow to select / change the Image / GCP / Output Coordinate System. If you are getting the message “GCP and image geolocation do not lie in the same area…” when importing the GCP data, review the GCP Coordinate System you have selected (It will be listed at the top of the GCP/MTP Manager window.  You can enter data as either X,Y, or Y, X ( I often see users transpose the X&Y).

Regards,

Aaron Woods