Orientation error caused by suspected GPS shift

Hi there,

I have recently being trying Pix4Dcatch on 3 different devices.
Samsung S22
Ipad 10
Samsung Galaxy Tab A7

The S22 I have had no issues on the capture.

The Ipad I have had a couple of issues where the GPS seems to adjust mid capture changing the height slightly causing a point cloud that isnt aligned and has multiple ground levels.

The Samsung tablet I have not managed to get a proper capture from despite numerous tries.
half way through the GPS seems to adjust and the alignment gets offset in all of the pictures after any adjustment.
Even if I havent moved the camera during the capture process I have watched the model shift from the previous photo, all pictures were from the same area and features however the processed output from the cloud has multiple distortions in elevation and orientation.

Is there a solution where the data can still be processed through the cloud or a way to fix the GPS shifting while capturing the intended target?

Hello there,

I’m sorry to hear about the problems you’re having with Pix4Dcatch on your devices. Here are some suggestions that may help:

Samsung S22: It’s great to hear that you’re not having any problems with this device.

iPad 10: The GPS offset issue you’re experiencing may be due to the GPS accuracy of the iPad. One suggestion is to give the iPad some time to acquire a good GPS signal before starting the capture.

Samsung Galaxy Tab A7: For the issues you’re experiencing with the Samsung tablet, it may help to perform a soft reset. To do this, turn off the device using the power button, wait about 10 seconds after the screen goes black, and then press the power button again to turn the device back on.

For all devices, make sure you’re using the latest version of Pix4Dcatch. If you’re using an older version, please upgrade to the latest version and try again. Also, make sure your internet connection is stable, as an unstable connection can cause problems during processes such as uploading.

If these suggestions don’t solve the problem, I recommend contacting Pix4D support or the Pix4D user community for further assistance.

I hope this helps! Let me know if you still have questions.

Fernando Torres Pix4D Technical Support Team