Support Website Contact Support Blog

Inspire 2 Straying From Grid

I did some surveys last fall with this exact same setup, everything was totally fine and now I took it out again having changed nothing and the drone is straying very far from the grid and also pausing for up to 30s at waypoints:

IMG_0112

In some cases it also shows photos are not being taken.

I’ve tried everyhting I can think of… multiple recalibration of compass, IMU, etc. there was virtually no wind, I have no idea why it’d be doing this. I’m flying a RededgeMX.

Anyone encountered this before? I can’t find anything on here about it yet…

Hello,

The behavior you are describing can’t be replicated on our side and has not been reported to us so far. I would suggest you go through all the basic checks and troubleshooting steps as it will solve most of the issues that can be encountered if properly followed.

Regards,

I’ve tried all the basic steps and troubleshooting and the issue persists. I was testing it again after trying these steps, and it seemed to be working a bit better until in the middle of a mission the drone took off sideways at full speed and began rapidly losing altitude. I flipped it over to atti mode and was able to recover it, but if I hadn’t acted quickly it would have for sure crashed the drone. The inspire 2 flies fine on it’s own, and pix4dcapture is working properly with my phantom 4.

There is for sure something wrong with how pix4d capture is working with the inspire 2.

Here’s a couple more screnshots.

IMG_0103 IMG_0104 IMG_0106 IMG_0108

Hello Tim,

Thanks for the screenshot. It is completely weird. This type of behavior hasn’t been reported by any other users so for and the issue is not replicated on our side. For now, I would suggest you to upgrade to the latest drone firmware, remote controller, and application and see if that helps.

Best,

The drone has been fully uploaded. I’ve calibrated the drone multiple times, including the remote control. I also checked the drone flight logs from one of the flights and everything looks fine: no warnings, good GPS, good compass, etc.

I’ve also tried reinstalling Pix4dCapture and it’s still doing it. I’ll try Pix4dCapture on a different device next, that’s the only thing left for me to try.