Support Website Contact Support Blog

How to use Discovery after update

I updated Pix4d to the latest version.  When I login, no lic. is found, which is correct. And “use Discovery” is selected, which is also good.  But the “OK” button is grayed out and I cannot see a way forward.  Any help would be appreciated.

Hi Dave,

Could you please confirm you have installed the latest version (4.0.24)?
If not, you can download it from here.

Hi Julie,

I’m not sure about the version I tried.  It was definitely 4.xx  I downloaded on 10-7.  I downloaded 4.0.24 and the problem is fixed.

I’d like to put in a request for a level of the product between Discovery and a 1 month rental. Maybe 3 or 5 projects for $100 or something.  You could have the program require a unique token per job and sell the tokens. I do this part time and would like to have Pix4D as an option but it’s just out of reach for the amount I would use it. Just a proposal.

Thank you for your support!

2 Likes

Hi Dave, 

We’re glad that it could be solved!

This pricing scheme sounds like an interesting idea, thanks for sharing!

Thumbs up for that pricing scheme. I’m also doing this part-time and the winter has arrived to Finland. There’s already snow on the ground here in northern Finland. I’ll probably have like 1 or maybe 2 projects during winter and I’m not going to pay that 260€/mo just to get those done. That scheme would fit me perfectly.

1 Like