Support Website Contact Support Blog

how to restore an older version of pix4d?

how to restore an older version of pix4d?
After downloading the last version that is available to me during installation, there is information that I have a newer version already installed. The newer version has uninstalled and is still the same information. What to do?

Hi Piotr,

What is the latest version that you can access with your license? And what is the newer version that you just downloaded?
Do you get an error when trying to open a project file (.p4d)?

I recently loaded the newest version of Pix4D Mapper (ver 4.3.31) after doing so, I then tried to open a recent .p4d project file and was surprised to see that all my previous work is apparently gone. I had been in the process of adding MTP’s to refine th model and now nothing, no point cloud, nothing where did it go?

Hi Peter,

Indeed this behavior is unexpected. Can you please send us a screenshot of the rayCloud and Result Folder? Are you able to see your results? Are the folders empty or you are just not able to see the outputs in the software?

Best