Support Website Contact Support Blog

Error w0014 - Tranformation failed

Hello

 

I have been getting error w0014 “Transformation of coordinates between GCP and output coordinate system fails or is not precise. Make sure you have selected the correct coordinate system”.  Both my output and GCP systems are exactly the same.  Is anyone else experiencing this?

Hi, 

Could you post screenshots of the image, GCP and output coordinate system windows with checking the “Advanced Coordinate Options” checkbox in the bottom left of the window as below?

Click Project > Image Properties Editor under Coordinate System click Edit…:

Click Project > GCP/MTP Manager under GCP Coordinate System click Edit…: 

Click on Project > Select Output Coordinate System: 

This will enable us to compare how the coordinate systems were defined. 

If they are the same, another possibility could be how the GCP coordinates were imported. Maybe they were imported as X, Y, Z instead of Y, X, Z. This will depend on your coordinate system. 

During which step of processing or after which action do you get the error message?

1 Like

That fixed it. I had the MSL button clicked, which I didn’t need being on state plane.  Once I put all those on 0 Geoid height, the error went away. 

I was getting the error whenever I closed any of the above 3 coordinate system windows, or whenever the project was first opened.  They are no longer giving me that warning now.

I am using WGS84 for images, and NAD83(2011) GA west ft. US for output and GCP.

Glad that the problem could be fixed. :slight_smile:

It happened again today on a new project with the parameters set as above.  I have attached screen shots of all 3 coordinate pages. 

This was a flown with a P4P and the GCP were all set using a RTK GPS system.

I will say that this does not seem to be affecting the created point cloud.  The RMS error on the GCP is .006ft and everything looks ok. 

very nice!

@Jake: I’m not sure to understand. Do you still get the warning “w0014 Transformation of coordinates between GCP and output coordinate system fails or is not precise. Make sure you have selected the correct coordinate system” or is the problem solved? The last comment seems to say that everything is fine. Let me know :slight_smile:

I am getting the warning on a new project now with the correct settings. 

I am getting this on all my projects now.  

When I select the output coordinate system at project creation, it appears that is directly copied to the GCP coordinate system when I go into the GCP/MTP Manager.  Everything is EXACTLY the same, yet I am still getting the error that the transformation between the two identical coordinate systems is failing.

At the moment I think it is more of a warning that an actual error that would affect the results.

Could you please confirm that results are correctly georeferenced? You can check this by importing e.g. GCPs and orthomosaic in a third party software (AutoCAD, GlobalMapper) and check if they overlay. Let me know.

I believe you are correct.  The results seem to be correctly georeferenced when viewed in Global Mapper. 

More good news is that with the new update I just downloaded, the warning is no longer happening.