error in bundleadjuster

sensor: rededge-p
seeting: ag multispectral
question: I used rededge-p for shooting, removed the non-in-flight images, and used the default agricultural multispectral mode for stitching, which gave an error in the first step of processing. The full text of the error is as follows.

> [Processing] : Preparing calibration[Processing] : calibrate
> [Processing] : Filtering
> [Error]:[BundleAdjuster][minimize]       no projections errors ! aborting.
> [Error]: Error in bundle adjustment
> [Error]: [ BundleAdjuster][minimize]      no projections errors ! aborting.
> [Error] : Error in bundle adjustment
> [Error]: [BundleAdjuster] [minimize]      no projections errors ! aborting.
> [Processing] : Preparing calibration
> [Processing] : calibrate

Can you attach your quality report and entire log file to this posting?

The splice file has all been deleted, I tried again, but it cannot be reproduced.

Now I found this problem during the stitching process of another task. Unlike the previous task, this task completed the stitching normally.

The quality report has been uploaded.

Quality Report.pdf (990.9 KB)

Thanks for uploading. What I noticed is that your GPU driver is quite old. This can cause many processing-related issues. You can download the latest driver for your NVIDIA Quadro P2200 at the link below. It is a direct download from NVIDIA. This might fix many of your problems.

Thank you for your reply and reminder.

This computer is a public computer, and few people take the time to maintain it. I’ll try to do a full drive upgrade.

in fact, I also tried the previous task on two other recently updated computers (referred to as B computers and C computers for short) and encountered the same message ‘error in bundleadjuster’. The CPU of B computer is 3700X, the RAM is 16G, and the GPU is GeForce GTX 970; The CPU of C computer is i7 8700, RAM is 32GB, GPU is GeForce GTX 2080.

Like this public computer, the task files were deleted, there was no reproduction, and there was no quality report.

It’s a strange question. When I deleted the task file and rebuilt the task, using the exact same Settings as the previous task, the task was complete.

Here’s what I know about the problem.

When it appears, the task completion time becomes longer, for example, the last task used about 8GB of images, the task execution time was more than 48 hours, and then I canceled the task and published this post. After deleting the task files and re-establishing the task, it only took 7 hours to complete the task.

Computer B and computer C performed the same task for more than 72 hours.

I will continue to upload quality reports here when I encounter this situation again, hoping to help with software optimization

Hi @18899597857 ,

Thank you for your reply. Like my colleague Mike said, updating the GPU driver will definitely help. You can follow the steps here to update it: How to update the driver for an NVIDIA graphics card
Are computers B and C also public computers?

You also mentioned the dataset is about 8GB. It seems like a medium to large size project.
Sometimes a larger project requires a higher hardware setup.
Feel free to check this article for your reference: Computer requirements - PIX4Dmapper

Also, the long processing time could be due to many reasons: using an HDD not an SSD hard drive, battery-saving mode when using a laptop, other GIS software being opened, or processing another project at the same time using another software, etc.

One way to ensure high performance or asks the GPU to prioritize for PIX4Dmapper is to go to Windows > Setting > Display > Graphics
You can set the graphic preference for PIX4Dmapper to High Performance.
If you cannot find PIX4Dmapper, you may browse it and add it.

Last but not the least, please make sure the detected GPU device is correct and checked in Mapper. Sometimes we have seen other GPU devices detected, such as an integrated GPU.

I hope this helps. If you are still experiencing a long processing time, feel free to share the computer specification file (.nfo). As well as letting us know how many images are in the project, what is the average resolution for each image?

  1. Click the Windows Start icon and type System Information. Select the application in the list above.
  2. In the application, click File > Save… and export the content.
  3. Attach the file your_file.nfo to the reply.

Always happy to help if you need it. :slight_smile:

Other references:
Hardware components usage during processing - PIX4Dmapper

Best regards,
Rosana (she/her)