Support Website Contact Support Blog

Error e0400b

Hello!

I get this error message when trying open my recent project.
I’m using version 4.3.27 and the processing was made in this version too.

I’ve tried the solution discribed in the knowledge base, but the XML file already have “Ceres” set in the optimizerType tag.

Any idea to solve this problem?
Thanks a lot!

Hello Rafael,

Would you send me a snapshot of the error? Does it say something else?

In addition, would you send me the p4d file and log file from the last session?

Thank you very much.

Hello!

Just the error code and the message “Invalid format”.

Here the snapshot…

 

How can I send you the p4d and log files?

 

Thanks

 

 

Hello again,

You can open a ticket through our support site: go to here and then “Contact Support”

or use systems like dropbox, wetransfer…

Thank you very much.

 

Here the files you ask… 

https://www.dropbox.com/sh/rqznthh318l77zz/AAC8Iundq3uYFrbPY871GNWaa?dl=0 

Hello Rafael,

The log file only has three lines, would you send me the complete one?

In addition, please describe what you have done exactly. Was the project processed before? In case so, please send me the Quality Report.

Have you changed anything in the project regarding folder paths? 

On another issue, I see that the RAM memory is already at 43% usage. Is there something running in the background.

Regards.

Hello again and thanks for your patience :wink:

I will start answer the second question.

  1. I made a clean install of version 4.3.27 (I restore my pc some weeks before)
  2. I Started a new project and run the processing phase after. (You can acess the quality report in the same dropbox link I send the comment before.)
  3. I saw the results of the processing and close the Pix4DMapper software.
  4. When I tried to open again the project I receive this error message.
    In addition: I have made some other experiences, a second attempt of this project (same number of images) and others with less images. The second attempt recieved the same error again. The other projects with less images, open fine.

Answering the other questions:

  • Probably I have deleted the log file (I have this habit) and the 3 lines in there reflects only the attempt of open the project and the error itself.
  • I don’t have changed anything related to folder paths. As I said, I made a clean installation of Pix4D with the default settings.
  • I don’t remember now if I had others applications running in background but most of the processing time was during the night. I’m testing this software in a modest PC configuration with only 8GB of RAM. Can this be the problem?

Sorry for the long comment but hope this can help you helping me :slight_smile:
I’m testing the software in trial mode and this error prevents me to made some other experiments.

 

[off topic question]
I realized that the mosaic tiles have 5000x5000. Is there any option to change this size? For a larger size?

Hello Rafael,

According to what you describe, it seems that the number of images is probably the reason why the project does not open again.

Indeed, 492 images with 8 GB of RAM is very little.

Anyway, it would be good if you could send me the log file including the first process. I would like to have a look

I would also ask you to try to process with less demanding parameters, for example, 1/2 for “Image Scale”, less density in the point cloud… By doing that, the software will need less RAM.

As for your off topic question, there is no way to change the size of the tiles but you can merge all of the tiles together and get only one file. Just check the “Merge Tiles” option:

Please let me know if having less demanding settings helps.

Regards.

I was not expecting the memory to be a reason not to open the project. If the processing was done completely, opening the project should be a simple thing.

I do not think I still have time to generate a new project since the trial period is ending, but if I can, I’ll try again using your suggestions.

Anyway, I’ll keep that suggestions in mind for a future use of Pix4D.

Thanks for the support

Hello again,

That error usually happens when trying to open projects from different versions but it seems that it is not the case here.

Since the project with fewer images works, I would think that is the reason for the failure. However, I would need the Log file of the failing project to be able to know better.

If you still have it or can generate it, please send it to me.

Thank you very much.

Hi!

I still had time for one more test where I try a different aproach with the same processing parameters.

I ran each step at a time and try to close and open Pix4D software in each one. That is, I ran initial processing only, I closed Pix4D and open the project again. No error. Then I done the same for the two remaining steps.

At the end I was able to open the project correctly without the error.

Thanks again for all your help.

Thank you for the feedback!