Support Website Contact Support Blog

edit the Orthomosaic


I am new to Pix4D matic. Is this a way for Pix4d matic to edit orthomosaic like in Pix4Dmapper?
Also, can I draw Process area (later use them in ArcGIS) in PIX4D matic?

Thanks a lot,

Hi @muli,

For the moment, there is no orthomosaic editor in Pix4Dmatic. Can you please give examples of cases when you would need this? I have some examples in mind, but would like to confirm that these correspond to what you are looking for too.

Same for the process area. Could you please provide examples and additional context to your workflow? e.g. when do you need this, for what purpose exactly and what about the usage of that in ArcGIS.

This will help provide context and will enable us to address this correctly in the software in the future.
Thank you!


Hi Pierangelo

Thanks for replying. I am looking for a way to trim the DSM and Orthomosaic edges after all processing to be able to only use areas away from the edges where there is enough overlap of the images.
And after exporting DSM, orthomosaic, I would like to view it in ArcGIS or Leapfrog, and use them for drilling planning in 3D.


Hi @muli, thanks for explaining why you need the processing area. Well noted. As for the orthomosaic editor, I assume it is for fixing areas that are not perfectly reconstructed, let me know if you have some typical examples where it doesn’t work, this would help us tune our algorithms as well. Cheers

Hi Pierangelo

When I exported and looked closely into the ortho, I found there are some strange aberrations. Some squiggly pixelated smears like in the images attached here,

Would you mind providing some thoughts on what are the possible reasons for this?

Great Thanks,

@muli thanks for sharing the screenshot. The information I received from the team responsible for this algorithm is that this usually happens due to noise in the DSM, specially in the borders of the orthomosaic. Increasing the surface smoothing in the DSM generation settings could improve it. The steps would be: increase the surface smoothing settings in the DSM, run the DSM and Orthomosaic again. Please let me know if that worked for you.