DJI Enterprise advanced compatibility with Pix4D Mapper


I was wondering if it was possible to process the radiometric thermal and RGB data from the Mavic 2 Enterprise Advanced in Pix4D mapper when the data has been collected using automated flights flown in DJI Pilot?

I have had success using data collected with an XT2/M600 combo when collected with DJI Pilot. But need to check before recommending the enterprise advanced.

Hi @katherine.james,

The Mavic 2 Enterprise Advanced thermal camera is not in our database. However, Pix4Dmapper is drone agnostic, meaning you should be able to process any image obtained from the drone.

Although Mavic 2 Enterprise Advanced thermal is a radiometric corrected thermal camera, the image EXIF format is not the same as the other thermal images rjpeg format which is why Pix4D is not able to use the FLIR SDK for conversion to tif and use them to produce thermal maps with temperature values. So, you can only generate thermal maps for visualization.
There is a workaround for H20T camera that is mentioned in this video, using our product PIX4Dmapper, with a conversion first… DJI H20T in Pix4Dmapper - ATygeo Thermal integration - YouTube . Maybe it could also work for M2EA Thermal.

The MAVIC2-ENTERPRISE-ADVANCED_4.5_8000x6000 (RGB) is already calibrated and added to the PIX4Dmapper database, so you should be able to process without any issues!

I hope you find this helpful!


1 Like

Mavic 2 Enterprise Advance is also compatible with ATygeo Thermal tool: ATygeo Thermal M2EA - Procesado de ortomosaicos térmicos con DJI Mavic 2 Enterprise Advance - YouTube

1 Like

I’m still working through this one. I collected a section of a building using DJI Pilot and ME2A that ended up being 186 individual images with the 90/90 overlap. I then used the ATygeo tool to convert to .tiff and attempted to process with Pix4DMapper. I initially used the ThermoMap template which failed quickly and then tried the 3D map. Each failed, but the 3D map got closer. The primary failure message was: "Dense matching failed with error: “failed to run a step!” (Failed!). The initial processing completed.


Project ME2A Practice
Processed 2022-08-31 19:59:08
Camera Model Name(s) MAVIC2-ENTERPRISE-ADVANCED_0.0_640x512 (Grayscale)
Average Ground Sampling Distance (GSD) 1.19 cm / 0.47 in
Area Covered 0.000 km2 / 0.0073 ha / 0.00 sq. mi. / 0.0180 acres
Time for Initial Processing (without report) 11m:22s


Are you processing the thermal images together with the RGB images?
If yes please try to process them separately by selecting the processing template Thermal Camera for the thermal images.



I initially discovered the ATygeo tool failed when the RGB files were in the same directory as the thermal images when I did the conversion. I separated the two groups into two directories to get the conversion to complete. So only the thermal files were in the project listed above. Those images were the output of the ATygeo conversion tool (.tiff).

What I have figured out is that I need to skip step 2 “Point Cloud and Mesh”, which is how the example video from Fede showed it (that video skipped step 2 as well). However, the final result was not to very pleasing, which may be my original data.

From here I intend to try again with the M2EA and also go with a couple of FLIR (XT2 13mm and XT 9mm) cameras for comparison since those tools are FLIR RJEG and can be used directly in Pix4DMapper.


I believe it was commented on in another post, but DJI and FLIR have not worked together on recent camera offerings. This includes the Mavic Enterprise 2 Advanced, H20T and the thermal camera for the Matrice 30T. The RJPEG for these images is different than the FLIR images generated by the XT and XT2 cameras. Since Pix4D doesn’t read this format at this time, a conversion is necessary.

I used the ATygeo tool, mentioned above and in other posts, and converted the images to TIFF. There appears to be independent conversion apps for each of the new DJI sensors (ME2A, H20T and M30T). I only own the Mavic, so that is the only test I have run. With this conversion, Pix4d does not need to perform this conversation as it does with FLIR RJPEG. Once these files are converted, Pix4D mapper will read them, but I still had issues.

There was another post about the DJI XT2 camera settings not “defaulting” to correct values. The DJI XT 9mm did correctly default but you need to correct the camera settings for the XT2. After reading that post I corrected the camera settings before starting the processing (particularly the pixel size). This is an issue with the Mavic Enterprise 2 Advanced as well.

Looking at the DJI site, the Pixel Size is 12 and the Focal Length is “about 9”. Inserting these two values into the camera definition has generated a respective thermal map.

I used the 3D Map Template for processing, with the camera adjustments mentioned above. Then the Index Calculator allows you to generate a Reflectance Map, Index Map and all the visualization of the Color maps seem to function as they do with the FLIR RJPEG Thermal images.

Note. Above I stated I had to “skip” the Point Cloud and Mesh (Step 2). With the correct camera settings step 2 completes with a point cloud.