Support Website Contact Support Blog

Disabled points in mesh

Hello, I’ve produced a point cloud and mesh. I’ve now been removing points in the point cloud to the point group ‘disabled’. Then i try to create a new mesh by the steps: Process -> Generate 3D textured mesh. Doing this at the start worked as intended and they didn’t add my disabled points. However, when i do this procedure now it adds the disabled points and the mesh is the same as before I generate a new 3D textured mesh. Please help.

See attachments for an example in the model on a pipeline. One is from the pointcloud (disabled points turned off) and the other from the same area in the mesh.

Hi Hanne. Where are you attempting to remove the points? If the points removed leave a hole in the mesh then it will likely be filled as it needs to be continuous surface.

I have removed points from the cloud, but it does not have any effect on the mesh. The points removed is what i believe is just noise beside the tube I am constructing. The image attached is after I have removed the points from the cloud. However the resulting mesh is still the same as before I removed the points.

Thanks for the image. In this case the large blank areas would leave holes in the mesh which is why they are getting filled. Unfortunately there is nothing that can be done within Pix4D to force these holes to be left in when generating the mesh.