Support Website Contact Support Blog

DeskTop, Pix4D Mapper, Survey scale error?

Hi, A relative level error has come to light with a survey iv just carried out.  

I have flown the stockyard of the mine I work at with DJI Phantom 4 Pro.  I used DroneDeploy to do the flight @ 100m above ground. I used 6 GCP surveyed in with RTK GPS.

The survey was also carried out with the RTK GPS on foot the old fashioned way to check.

The problem I have found is the base of all the stocks is about 600mm higher than it should be when compared to the on foot survey (and some known ground levels).  The tops of the stock piles are not bad but a little above where they should be.

The overall GCP error was 75mm and none of the GCP stations was more then 120mm different from where it was surveyed.

Iv done a similar survey before with no problems.

Any ideas what the likely cause is?

This is a link to my quality report:

https://www.dropbox.com/s/ob46b5s86lysx0a/Coalyard%2025th%20JAN_report.pdf?dl=0

I think the problem is Camera Optimization. 18% difference is way too high. Try re-optimizing the project after step 1. If that doesn’t help. Run the step 1 again and change the Camera Optimization to “All Prior”

Thanks Jaakko,  Using the “all Prior” fixed it, I now need to learn how and why.

Hi All,  Iv watched a few videos and read some stuff but I cant understand this calibration subject.  Has anybody got an idiots guide to carrera calibration?  I’ve just had another project where the calibration was not great.  The “All Prior” processing option fixed it but I don’t know how and what its doing.

In initial processing pix4d software tries to optimize the camera model. If the used camera is found in camera database the model of the camera is supposed to provide good initial parameters. If that’s the case you can “tell” the software to trust these parameters and use parameters found in database as optimized parameters and remain close to these parameters during step 1.

https://support.pix4d.com/hc/en-us/articles/205327965-Menu-Process-Processing-Options-1-Initial-Processing-Calibration

I’ve read the support pages, but its just beyond me.  Without understanding the process from first principles I can’t understand what is going wong.

GCP placement, large change in terrain levels over the survey, wind, the drone flying too fast, change in light levels, faulty drone…

and “Forces the optimal internal parameters to be close to the initial values” what “initial values”?

https://info.photomodeler.com/blog/camera-fundamentals-and-parameters-in-photogrammetry/

So from reading that, the one thing that I can think of being a problem at the moment would be temperature.  The drone is coming from a walm office (25deg) to flight (1-2 deg) in about 10min.

any thoughts?

Would the “initial values” be the calibration from the first few images?

Temperature during flight might be one cause for the camera parameters being far from optimized intial parameters or it could be something else. You should always check the quality report. There’s a lot of information what might be the cause.

This one is from Peter’s quality report. Small change in focal length seemed to be the problem

After all pix4d is just a computer program and sometimes it needs a push to make it go to right direction or you could end up with good looking bad map

Ah, the mist is clearing. That’s my report. But what could make the focal length change, a problem with the auto focus?  Are the initial values from the database.

As the optimized values are calibrated from the drone images, would the fact that most of my images are of grey / black stuff be a problem?

Initial values are from the database and my guess is that the monotonous/grey/black pictures are the cause. I’ve had similar problems when mapping large areas of tarmac.

1 Like

Thanks