Support Website Contact Support Blog

can't merge projects (linear projects)

I have a linear project of 2000 photos, for a 20 km x 25m corridor, with images captured in 6 flights using PPK technology, so I don’t need 3D-GCP’s, just checkpoints. If I process all the project as a whole I get a rotation in my model at the middle. Hence I processed each flight separately and got good individual results. Now, after this, I have not been able to merge any combination of two or more subsequent projects (tried first merging all), I get a failure at the very end of the merge projects process. This procedure had worked for me for other linear projects. Any ideas?

I get this message:

Writing tie points images done (Failed!)

Log details:

[2018.02.23 19:37:20][28%RAM][41%CPU][Info]: *****************************************************

[2018.02.23 19:37:20][28%RAM][41%CPU][Info]: \*\*\*\*\*\*\*\*\*\*\*\* merge cameras and tie points \*\*\*\*\*\*\*\*\*\*\*

[2018.02.23 19:37:20][28%RAM][41%CPU][Info]: \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*

[2018.02.23 19:37:22][25%RAM][48%CPU][Info]: \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*

[2018.02.23 19:37:22][25%RAM][48%CPU][Info]: \*\*\*\*\*\*\*MergeProcessing\*\*\*\*\*\*\*\*\*

[2018.02.23 19:37:22][25%RAM][48%CPU][Info]: \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*

[2018.02.23 19:37:22][25%RAM][48%CPU][Info]: merge project 0 WE\_Flight\_034

[2018.02.23 19:37:27][31%RAM][44%CPU][Info]: 0 common tie points

[2018.02.23 19:37:27][31%RAM][44%CPU][Warning]: No common tie points or cameras: effective GPS bias rigid transform: scale 1 trans -1245 -58 5

[2018.02.23 19:37:27][31%RAM][44%CPU][Warning]: RotationMatrix xyz -0 0 -0 opk 3.14159 -0 0

[2018.02.23 19:37:27][31%RAM][44%CPU][Warning]: 1 0 0

[2018.02.23 19:37:27][31%RAM][44%CPU][Warning]: 0 1 0

[2018.02.23 19:37:27][31%RAM][44%CPU][Warning]: 0 0 1

[2018.02.23 19:37:27][31%RAM][44%CPU][Info]: NrNewCameras: 0 nrExistingCameras: 0

[2018.02.23 19:37:53][38%RAM][14%CPU][Info]: GCP \<10\> not enough cameras

[2018.02.23 19:37:53][38%RAM][14%CPU][Info]: GCP \<22\> not enough cameras

[2018.02.23 19:37:53][38%RAM][14%CPU][Info]: GCP \<23\> not enough cameras

[2018.02.23 19:37:53][38%RAM][14%CPU][Info]: nrTracks 3454167

[2018.02.23 19:37:54][34%RAM][14%CPU][Info]: merge project 1 WE\_ChepicaT2\_36

[2018.02.23 19:37:55][34%RAM][13%CPU][Info]: 0 common tie points

[2018.02.23 19:37:55][34%RAM][13%CPU][Warning]: No common tie points or cameras: effective GPS bias rigid transform: scale 1 trans 1868 87 -7

[2018.02.23 19:37:55][34%RAM][13%CPU][Warning]: RotationMatrix xyz -0 0 -0 opk 3.14159 -0 0

[2018.02.23 19:37:55][34%RAM][13%CPU][Warning]: 1 0 0

[2018.02.23 19:37:55][34%RAM][13%CPU][Warning]: 0 1 0

[2018.02.23 19:37:55][34%RAM][13%CPU][Warning]: 0 0 1

[2018.02.23 19:37:55][34%RAM][13%CPU][Info]: NrNewCameras: 0 nrExistingCameras: 0

[2018.02.23 19:38:07][36%RAM][13%CPU][Info]: GCP \<24\> not enough cameras

[2018.02.23 19:38:07][36%RAM][13%CPU][Info]: GCP \<25\> not enough cameras

[2018.02.23 19:38:07][36%RAM][13%CPU][Info]: nrTracks 4841913

[2018.02.23 19:38:07][36%RAM][13%CPU][Error]: No calibrated cameras.

 

Hi Jose,

Would it be possible to share with us the following for the final project created by merging the sub-projects (e.g. via WeTransfer)?

  • The project log file (text file): …\project_name\project_name.log
  • The project file (.p4d): …\project_name.p4d

And for each individual sub-project ideally (only two if you have many):

  • The quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf
  • The project file (.p4d): …\project_name.p4d

I have had the same error appear while trying to do a similar activity. Are there any updates on how this occurred? I have other issues with my project too so I may post them separately

@Sci.Areo, at the moment it is not clear what could cause the issue and we would need additional information in order to get an overview of the situation.

Could you submit a support ticket using the request form including all the information we requested in the previous comment?