Support Website Contact Support Blog

Calibration Image Scale

In Pix4DMapper the image scale in the calibration step is automatically reduced to half for images above 20mp. Does P4DMatic do the same thing or leave it at full scale?

Hi @Andrew_Milanes,

For the moment processing options do not adapt to the images in Pix4Dmatic, but you can make the change manually.

Would this be something you’d like to see in Pix4Dmatic too? I assume this would be a gain in time for setting up the project. Let me know if there are other advantages.

Thank you.

No this is not a feature request. I wanted to know if Matic and Mapper handled large images the same way. I have a Wingtra with 42mp images. I am testing Matic on a very large project (11,510 images). The calibration step in Matic is slower than Mapper. I was trying to figure out why.

Yes, you probably identified the culprit, the image scale will have an impact on the processing speed. Let me know if Matic is still not faster after that, this would be something we should look into. Also make sure you have the latest version installed, but you probably already have.

We’re going to look into adding processing option templates further down the road, which will automatically select the right options for optimal processing.

Thanks. I plan on processing this project with both and compare results.

I do have one more question. For the DSM resolution, I cannot enter 0.05 feet, which is the GSD of my project. It defaults to 0.1 feet. Is this just rounding 0.05 to 0.1 in the display or is it actually reducing the resolution by half?

@Andrew_Milanes it seems that the min/max values in the resolution field are limited to: 0.1 to 9999 (cm or ftUS or ft). In the metric system this makes sense as it corresponds to about 1mm, but I see the need to adapt this min value for the ftUS and ft to the equivalent of the 1mm. I will make sure it gets prioritized. Thanks for reporting it! Let me know if you find others like this.

So does this mean my DSM and Ortho will be reduced to half resolution if I leave the default?

Right now, if your GCPs are in feet, the minimum resolution that can be set for the DSM is 0.1 feet. In your case, this would mean that the resolution would be double the one of the GSD. This is a bug and will be fixed. Normally, this will be part of the next preview release next week. I’ll keep you posted. Sorry for the inconvenience and thanks for reporting it!

@Andrew_Milanes the issue you reported with the DSM resolution was fixed in the preview version 1.8.0 released today, you can download it here: https://www.pix4d.com/download/pix4dmatic

We set the new minimum value for the DSM resolution to 0.001 feet instead of the 0.1 feet that were applied before. This makes it equivalent to the minimum value of 1mm when a metric coordinate system is used.