Support Website Contact Support Blog

Calibrated camera locations are landing "in the raycloud" or "very high above the raycloud" when flying Phantom 4 RTK

Hey all - 

Flying a phantom 4 rtk. After running step 1 with all stock settings I am getting the calibrated cameras landing in the raycloud. Screenshot is below. Sometimes, after re-running part 1 (and adjusting the geotags to 0.02m) the project fixes itself. It doesn’t seem to happen with any pattern, but happens about 50% of the time. It happens when the p4rtk is set up in GNSS mode with no post processing (so the geotags are accurate to 5m), and when it is set up with the DJI Mobile base station, and with VRS (so the tags are corrected to 0.02m).

Has anyone else seen this before? Any thoughts on how to stop this from happening when running part 1?

Hi, 

If I understand correctly, the reconstructed model (automatic tie points) are on the same height as the images. Is that correct?

This is not expected and we do not have other users reporting a similar issue at the moment. Could you check if there are some issues with the camera optimization in the quality report? Is the difference between the initial and computed camera parameters close to 0% or not?

Best,

Hi Blaz, your understanding is correct. The automatic tie points are at the same elevation as the images.

You’re also absolutely correct. The camera parameters differ widely from initial to optimized.

I have attached the summary and camera calibrations from a sample report below. Let me know if I can help provide anything else.

 

Indeed, camera optimization is not optimal and this is why the cameras end up close to the generated points. 

A quick solution would be to use the All Prior option. This will fix the camera parameters and will force them to stay close to the initial values.

To get more insights into the possible root causes and solutions, I would highly recommend checking the Processing Issue -> Step 1. -> Camera Optimization section in the Pix4Dmapper troubleshooter

Best,