Support Website Contact Support Blog

Artifacts in point cloud : roads, shadows,...

Hi everybody,

I am using pix4D to process images from the drone WingtraOne. My main outputs are point clouds, DSM and orthophotos. I noticed some mistakes in the point cloud : when an area is under a dark shadow, the points can have mistakes in height up to some meters ; roads have often a thickness of several centimeters (more than expected) ; … I am assuming that this is the results of mismatching pixel in pictures, due to large contrasts or no matching for roads. Did you ever noticed this kind of issues ?

You can download examples here ## grosfi.ch/4EGcCW8yXqg

Thank you in advance for your help.

Roxane

Hi Roxane,

Could you please share here with us the Quality Report of your project plus some screenshots showing the issue? I’d help us solve the problem faster.

Thank you in advance!

For the shadow :
19832_TPC_report.pdf (217.2 KB)

For the road :
20121_dorenaz_report.pdf (348.5 KB)

In my first message you can directly download the point cloud

Seems you are alredy using Cloudcompare. Have you tried the SOR filter yet?

What would you recommend as parameters ? For now, I am doing manual cleaning because these tools are not cleaning all the wrong points.

It’s kind of trial and error. Try different settings. Start with the settings that cloudcompare suggests and after that try different setting and you’ll get the point how the filter works.

Hi,

Thank you for all data. The issues you’re dealing with are common for photogrammetry projects - uneven homogenous asphalt surface, errors in the shaded area. I believe that the best practice would be to generate the best possible result in Pix4Dmapper. And, later if necessary, improve it in third party software. As you probably noticed, our software doesn’t have a wide range of tools that would filter the point cloud. Yet, we have an option that in specific projects works very well - it fills the holes, completes the results, especially vegetation. But, in other projects creates too much noise. It’s Multiscale option I’m talking about. And I think that in your project you should disable it. Could you try that and let me know whether it improved the results a bit?

Regards