Support Website Contact Support Blog

About Phantom 4 Pro+ v2.0

I saw pix4D  is not compatible on PH4 pro+ v2.0.

Does pix4D have plan to support PH4 pro+ v2.0?

If pix4D has a plan, then when?

Hi,

It is not in the pipeline to officially support the Phantom 4 pro+ V2.0. I would suggest you to follow the main thread for this specific subject. We will communicate there if any updates about the current status of the P4P+ V2.

To avoid having too many threads with the same subject and that information remains easily accessible for users, I will close this post for comment.

Best,