Support Website Contact Support Blog

3D Topo of Structures Not Generating Contour Lines Between Structures & Ground

I’m having an issue when I render topo of anything that is in the air basically. I can’t figure out how to stop rendering topo lines in an area where there isn’t anything. I always get contour lines from the top of the structure to the ground, no matter the elevation change. And the topo that I do get always has spikes in elevations.

That’s the way they look. I would like to have 0 contour lines between the bottom of the structure and the ground, so that when I go into 3D view in CAD I would be able to differentiate the structures from their surroundings. Also, what is causing the spikes in the tops of the structures? Everything around them are in good shape, but no matter what they always spike like that.

Hi,
Are you using DTM or DSM to generate the contour lines? What is the outcome that you want to achieve?
I would recommend to you to generate contour lines using DTM rather than DSM. When using the DTM, the whole point cloud is assigned to disabled, except for the ground and roads which are used to create the desired contour lines of the terrain only.
You can go through our articles on How to generate the contour lines and Menu Process > Processing Options… > 3. DSM, Orthomosaic and Index > Additional Outputs to learn more about it.

If the automatic point cloud classification is not good enough, you can manually edit the point cloud before generating the contour lines. You should assign everything except ground and roads to the disabled group and run step 3 again. You can find more info about how to edit the point cloud manually here.