Support Website Contact Support Blog

systematic color imbalance in orthophotos

I flew with 80% forwardlap and 60% sidelap with terrain following in UGCS.  It looks like the terrain following waypoints were not detailed enough and I didn’t get solid overlap in all places.  It seems like this could be the cause of the color imbalance in the ortho, but I’m not sure and hope there is a way to correct.

 

 

 

Hi Jonathan, 

Seeing the information you provided and the screenshots, we think the issue may be coming from camera calibration (Step 1). 
Could you provide us with your Quality Report here, so that we can get a better sense of the overall processing?

We see that the area of your construction does not have a lot of unique features, which could be why the software is having a difficult time detecting keypoints. 
To improve the results, we suggest trying the following options in Processing Options.

  1. Select **1/2 (Half image size) **for Keypoints Image Scale: Menu Process > Processing Options… > 1. Initial Processing > General
  • This scale is recommended for blurry or low textured images, as it usually results in better outputs than the full scale for such images.
  1. Check  Use Geometrically Verified Matching:  Menu Process > Processing Options… > 1. Initial Processing > Matching
  • Slower but more robust. If selected, geometrically inconsistent matches are discarded. Useful when many similar features are present throughout the project: rows of plants in a farming field, window corners on a building’s facade, etc.

Regards, 

Hello Agent,

 

Thank you so much for having a look.  I tried your processing suggestions above and it did not seem to make much of a difference, unfortunately.  Hopefully the processing report will provide some clues.

 

Regards,

 

Chris

Thank you very much for providing us with the Quality Report. 

We have two suggestions for your case.

 

  1. I see that your camera model, FC6310_8.8_5472x3078(RGB), is not included in Pix4D’s current internal camera model database. We recommend you to use the full resolution, which is included in the database, for next time. 

For this project, we recommend you to set the camera parameters to the values highlighted in yellow here: 

 

  1. Using the “All Prior” option for Internal Parameters Optimization:  Menu Process > Processing Options… > 1. Initial Processing > Calibration
  • This option forces the optimization of the internal parameters (principal point, focal length, distortions) to stay close to the initial values.

 

Regards, 

Hello,

 

I began to try suggestion 1) and after loading the images I noticed that camera parameters matched what you have highlighted in yellow.  I tried suggestion 2) but got a similar result as above, except the camera optimization was 0.05%, compared to 44% with default settings.

I hope there is something else that I can try to resolve the issue?  Many thanks.

 

Chris

We would need more details to investigate the problem.

Please upload your project to Pix4D Cloud as described here:
How to upload project files from Desktop to Cloud.

Also, please zip the following and upload here: OneDrive
▸ The latest version of quality report (.pdf format): …\project_name\1_initial\report\project_name_report.pdf
▸ The latest version of project file (.p4d): …\project_name.p4d

Regards,

Thank you for the great support.  I have uploaded the files that you requested (above).  Please let me know if I missed something.

 

Regards,

Chris

Thank you very much for uploading the files. 

We have investigated your project, and we can confirm that your initial idea was correct; it is the lack of sufficient overlap that is causing the color imbalance in the Orthomosaic.

It seems that the mission planning app used the full resolution camera model to calculate the waypoints for the 80%/60% overlap, even though you were not using the full resolution model, which then caused the images to have less than 80%/60% overlap. 

We kindly suggest to use the full resolution of the camera model next time. 

Nevertheless, the accuracy of your project should not be affected by this color imbalance in the Orthomosaic. 

Regards,

Thank you for this support, it has been very helpful.

Chris

Follow up: PLEASE HELP!! orthophoto still has color imbalance

Could you check if the lines are also visible in the final orthomosaic? In most cases, the lines are only visible in the Preview Orthomosaic and they do not appear in the final Orthomosaic. This is due to the fact that the color balancing algorithm is applied in the final Orthomosaic and corrects the lines in most cases. The color balancing is not enabled for the Preview Orthomosaic. 

Please also upload the latest quality report here: OneDrive 

Best, 

Thank you for the support.  I have uploaded the quality report AND ortho and DTM.  The color imbalance is still very apparent in the ortho.  Thank you again for having a look.

 

Regards,

Chris

Hello, 

I am still hoping to get a solution to this.  Please, HELP!

 

Regards,

 

Chris

Hi Jonathan, after inspecting the files and the quality report, we could notice that none of the above suggestion was taken into consideration.

As mentioned in one of the previous replies, we suggest to use the full resolution of the camera model next time and increase the overlap. From the pattern seen on the orthomosaic it would be beneficial to increase the side overlap.

Best,