Support Website Contact Support Blog

PPK image geolocation accuracy

Hi all,

we recently did some mapping flights. Raw coordinates were recorded with Emlid Reach RS+ and M+ and then post-processed to centimeter-level accuracy with rtklib. Afterwards an almots fully automated workflow generates us a .txt file where each image is namely listed with the corresponding coordinates. This file can then be loaded in the Image Properties Editor.

Each flight is ppk’ed independently and thus has its own horizontal and vertical image accuracy per flight and image. This means that editing the vertical and horizontal accuracy for all images in the Image Properties Editor would ignore the fact that every image has its own accuracy. Setting the accuracy per flight is a possibility but this is also only an approximation because you should take the mean accuracy of the images per flight.

I would like to import the .txt file with its centimeter-level coordinates and accuracy values so that each image obtains its own precise coordinates and accuracy. I tried to build a comma-separated .txt file (name,x,y,z,hor_acc,vert_acc; without a header) but Pix4D will only consider the xyz-coordinates.

Is there way this can be done? Is the .txt file formatted incorrectly?
Edit the EXIF data? How?

Kind regards
Till

Hi Till,

I think the reason why you cannot import the values is that the orientations are missing.

When importing accuracy values, the files also needs to include orientations (Input files article):

  • imagename,
  • latitude [decimal degrees] / X,
  • longitude [decimal degrees] / Y,
  • altitude [meter] ,
  • omega [degrees],
  • phi [degrees],
  • kappa [degrees],
  • Accuracy Horz [meter],
  • Accuracy Vert [meter]

If you do not have the omega, phi, kappa angles, you can try to get them as mentioned in the Phantom 4 RTK - PPK processing post (see item b).

Best,

1 Like

Blaz,

thanks for pointing me to that thread. Although i read it in the past, i missed what was present in there :slight_smile:
Seems our problem is solved now.

Since we do not have omega, phi or kappa values, i assume that setting them to zero will force Pix4D to compute them from scratch.

Thank you very much.

Correct, if you do not have angle values then you can use “0” in the text file.

Let me know if you have any other questions :slightly_smiling_face: