Support Website Contact Support Blog

Pix4d Outputs Have Vertical Coordinate System Assigned

For the first time during my last few mapping flights I have used a PRJ to assign the horizontal coordinate system (NAD1983 Montana State Plane Int’l Feet). I set the vertical to Arbitrary and the units used are feet. However the outputs (ortho, DSM, and DTM) are assigned the horizontal from my PRJ but are also assigned the vertical coordinate system of NAVD88 Meters. So when I import these into AutoCad it thinks my numbers are meters and my drawing is feet so it multiplies the values by 3.2808 resulting in elevations of 17,500 feet when the actual elevations are around 5400. I have been through every setting and cannot figure out where to change this. So I have taking copies of the outputs and changed them using ArcGIS. 

Hey Curtis,

Could you please send me a screenshot of the PRJ file content?

I would also suggest to use GCPs measured in the desired vertical coordinate system, import them in Pix4D and then define the vertical coordinate system as Arbitrary.

The vertical coordinate system of the images can be set as default, because Pix4Dmapper will “respect” the GCPs´altitudes and give coordinates on the entire model based on these altitudes. 

Let me know if this worked.

Cheers,

Teodora

Hello again,

In case you are not using GCPs, it is highly unlikely that Pix4Dmapper assigns the output vertical coordinate system in NAVD88, because this system is not in the database. The only vertical systems you can choose from are WGS84, EGM 96, EGM 84 and EGM 2008 Geoid. For more information, please read our article: https://support.pix4d.com/hc/en-us/articles/360021076212-How-to-define-Pix4D-outputs-with-respect-to-a-Geoid-model

Regarding the visualisation of meters instead of feet, can you please check if Pix4D is displaying the output units in meters or feet? Open your project in the rayCloud and look on the right tab as in this screenshot:

Can you also check if the units in AutoCAD are set by default? Due to the fact that AutoCAD is not a geographical software like GIS, it might be that it does not automatically take into account the internal geographical units of an external dataset.

Let me know when you have updates.

Best,

Teodora

Hello,

I am using GCPs and have set the Vertical Coordinate System in Pix4d to Arbitrary. I did double check the project too and the output units are also feet. 

PRJ Contents:

PROJCS[“NAD_1983_StatePlane_Montana_FIPS_2500_Feet_Intl”,GEOGCS[“GCS_North_American_1983”,DATUM[“D_North_American_1983”,SPHEROID[“GRS_1980”,6378137.0,298.257222101]],PRIMEM[“Greenwich”,0.0],UNIT[“Degree”,0.0174532925199433]],PROJECTION[“Lambert_Conformal_Conic”],PARAMETER[“False_Easting”,1968503.937007874],PARAMETER[“False_Northing”,0.0],PARAMETER[“Central_Meridian”,-109.5],PARAMETER[“Standard_Parallel_1”,45.0],PARAMETER[“Standard_Parallel_2”,49.0],PARAMETER[“Latitude_Of_Origin”,44.25],UNIT[“Foot”,0.3048]]

Hello again,

The PRJ is fine, the units are international feet.

So the units displayed in Pix4Dmapper are international feet, right? This might be an AutoCAD issue. Please check the units displayed in AutoCAD.

Cheers,

Teodora

Yes Pix4dmapper is set to international feet. However given the settings in Pix4dmapper seeming to be right, the products froom Pix4dmapper (ortho, DTM, DSM, etc.) all have a vertical coordinate system assigned when viewed in ArcCatalog or AutoCAD with the units in meters and cannot track down where this is coming from. 

 

Hello again,

I recommend contacting the AutoCAD technical support, because I am not very familiar with their software. Alternatively, you could try multiplying the meters by the conversion factor for feet. I cannot think of anything better at the moment.

Cheers,

Teodora

Hi,

I was researching on the internet and I found this: https://knowledge.autodesk.com/support/autocad-architecture/troubleshooting/caas/sfdcarticles/sfdcarticles/Drawing-that-opens-with-units-set-to-millimeters-in-AutoCAD-opens-in-feet-in-AutoCAD-MEP.html
Maybe it helps.

Best

I know how to fix it. I’m trying to figure out why Pix4dmapper is doing this with my outputs, it’s inconvenient to have to go in with ArcGIS and change the vertical coordinate system units back to feet.

As I mentioned, we are still not sure if this is a Pix4Dmapper or an AutoCAD issue. One test would be to save the output from AutoCAD back into a local directory and open it in a 3rd party software to see if the units have changed again.

Cheers,

Teo