Support Website Contact Support Blog

Huge misclose in height

Hi there,

Thanks in advance to anyone who will help me with this matter.
I flew a Matrice 200 with ppk loki. Set up my base logging the static and I have sprayed 4 GCP’s to use as check.

Back in the office I processed the images in ASP suite and I run the initial processing.
I had a huge difference in 3D position (1m X 1m X 9m).
I can’t explain why.
I made sure base was on the right co-ords. I used the same projection, I checked the gcp’s on the field…
Camera calibration was correct
I asked a colleague to run the whole process again and he had the same error.

What can I have done wrong?

Then I went back to the field and picked up with RTK more natural features to use as gcp’s and check’s.
Re-run the initial processing, mark the gcp’s (8) and check’s (4) and reoptimize.
This time I have correct 2D position (within 50mm), but still height misclose between -0.319 and +0.189 with few check coming ok around 0.011 and 0.060…

I hope I explain myself clear enough.

Thanks guys

Hi,

I am not very knowledgeable in ASPSuite, but something might have gone wrong during the PPK corrections. Have you also tried the free software RTKLIB, in order to cross-check the values of the PPK corrections?

Concerning the geotags, have you converted the original CS of the images during the PPK corrections? If yes, please make sure that the vertical and horizontal CS of the image dataset and GCPs are correctly imported in Pix4Dmapper. As Pix4Dmapper does not recognize local geoid models, I would recommend transforming the vertical CS externally and then import the transformed dataset in Pix4Dmapper. Setting the same vertical CS for both the images and output will ensure that Pix4Dmapper is not performing any additional conversions.

When importing images with precise PPK-corrected geotags in Pix4Dmapper, you need to ensure that you have adjusted the accuracy associated with your images in the Image Properties Editor. By default, Pix4D assigns your images a 5-meter accuracy in the X and Y direction and 10 meters in the Z direction. Make sure to appropriately adjust the accuracy associated with your imagery before processing. In the image below I have highlighted the two fields in your Image Properties Editor that need to be adjusted. You can read more about changing your image geotag accuracy HERE.
When using RTK/PPK technology, image accuracy should be much better (few centimeters). If there are no GCPs in the project, the absolute geolocation is taken by the images’ coordinates. The software needs to know how much to trust these coordinates, this is why setting the correct accuracy is important.

Cheers,
Teodora

Hi Teodora,

I did convert the images from the ellipsoidal height to the Australia Height Datum with asp suite.
I imported Images, GCP and output with ( I tried everything) Geoid above ellipsoid = zero

I did check my X Y accuracy and I got 0.020 for all the images…

I’ll try with RTKLIB.

Thanks

Captur1e

Hi,

Could you please send the quality report, in order to closely analyze the problem? The quality report is in .pdf format and can be found in the following computer path:
…\project_name\1_initial\report\project_name_report.pdf

Cheers,
Teodora