Support Website Contact Support Blog

Having problems creating the reflectance map

Hi, we are trying to generate a big reflectance map. We have already done steps 1 and 2. Now, we are trying to get the reflectance maps, but the software crashes. Here is the output register:

 

[Processing]: Loading point cloud

[Processing]: Generating DSM tiles

[UI]: Processing Options clicked.

[Processing]: Substep Ortho index reflectance started.

[Processing]: Loading ortho images [Blue]

[Warning]: Load ortho: skip image \<IMG\_0000\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0219\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0247\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0275\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0303\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0331\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0359\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0413\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0440\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0466\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0492\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0549\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0577\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0607\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0609\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0625\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0626\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0627\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0000\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0016\_1.tif\>: image is not calibrated

[Warning]: Load ortho: skip image \<IMG\_0084\_1.tif\>: image is not calibrated

[Processing]: Generating reflectance map tiles [Blue]

[UI]: Processing Options clicked.

[Error]: Failed to write Exif!

[Processing]: Substep Ortho index reflectance finished.

[Processing]: Step2Done

 

Do you have any clues what could be happening? Is there anyway to send it to process in the cloud including 2D geografical MTPs corrections?

Thank you

Hi Jose,

Can you tell me which version of the software you are using? Could you please download the latest preview of the software from https://cloud.pix4d.com/download/ and try to process your project using this version? 

If that does not work, could you share the dataset with me so I could test it from my side (you can also open a ticket)? The easiest would be if you could upload it to cloud directly from the desktop so I would use the same processing options as you. To upload it to the cloud please see the instructions given in this link: https://support.pix4d.com/hc/en-us/articles/202558589-How-to-upload-project-files-from-the-desktop. You can share the link with me once you have uploaded.

Hi Momtanu,

I’ve been experiencing exactly the same problem as Jose. When Mapper goes to create reflectance maps in the third block of the processing it gets bugged. Unfortunately, I see there was no more info or resolution to this problem in this post. In my case, Mapper went crazy, it was still running for more than 12 hours after starting to process -my laptop kind of hijacked- and Mapper never ended. I had to stop it “using the force”.

The message I get in the log is the same:

[Warning]: Load ortho: skip image \<DSC00412\_geotag.jpg\>: image is not calibrated

I got it for all the 265 RGB pictures of my dataset.

I guess I am using last version of Mapper (v4.3.31) as I installed it last week.

Hopefully you can provide some help here.

Hi Pablo,

Are you using RGB images or multispectral? In both cases, if you use the ag template, it uses alternative calibration (which is optimized for vegetation). However, the pipeline is based on the assumption that the images are nadir. If not, the images will not calibrate. 

The way you will understand if this is happening:

  • Open your log file and search the word oblique (ctrl+F)
  • If you find the word oblique, process with standard calibration method.

Many thanks, Montanu.

I’ll try that one.

Regards

Hello Pablo,

I am facing the same issue of calibration with NIR images. Did your problem get resolved, if yes, then what was the problem and how you solved it?

Also, a set of images that were orthomosaiced with the previous pix4D version could not be orthomosaiced with the updated version. Is the new version causing issues?

Thanks

Sayantan

 

Hi Sayantan,  

We have looked at your quality report and replied to your support ticket. We looked at your images in QGIS and it seems it is a modified camera with 3 bands (not only NIR but NIR, Red and green). So you need to use ag modified template and select  TetracamADC_8.4_2048*1536   camera model from Image properties editor. Also, use all prior in internal parameters optimization. Multispectral cameras have separate sensors and one image for each band. However, modified cameras are composite images where the images of each band overlay each other.