Support Website Contact Support Blog

Altitudes too high and too low in DEM

Hello,

I have produced a 50 cm digital surface model (DSM) with means of 82 aerial images. When I compare my result with other DSM of the same region(profile elevation and differencing) it becomes clear that the DSM i produced has too high altitudes in the northwestern part of the area and too low values in the southeastern. I have run the process with and without GCP and I always end up with the same result.

Am I computing something incorrectly?
regards

Hi mate,
could you give more information about the flight? like drone, report of the project, software planning used…etc.
Could be that your flight it is straight and with certain unevenness in elevation?

Regards

Hello Joan,
the images have altidutes from 969 - 977m above sea level.
Here is the report of the project:

Mosaic_nr5_with_GCP_50cm.pdf (1.4 MB)

Regards

Some things:

  • the GCPs are in a relatively close area or are they scattered throughout the flight area?
  • I see that you have not applied the geoid. If you are going to use GCP and your images do not have RTK precision, you should apply it when you choose the coordinate system.
  • What type of targets have you used? Are all targets correctly marked on the verified images?
  • Try if you want to process step 1 using the option “use geometrically verified matching”

Q1: The GCPs are in a relatively close area so this is what I thought would cause a problem, therefore I did the processing as well without GCP and then I used a coregistration on the DEM without GCPs to correct the offset, but I end up with the same result as with GCPs.

Q2: The heights of the GCPs are defined as elliptic heights in the dataset. Do you mean I should select the geoid as vertical coordinate system when I import the images?

Q2: I have use the checkerboard mat GCPs placed in the landscape and they are all correctly marked on the verified images.

Thank you for taking time helping me!

Q1: yup, it could be. https://www.youtube.com/watch?v=DxiO4DZHtNA&t=266s
Q2: Ok, if the gpc are in ellipsoidal coordinates you don’t need to apply the geoid
Q3: Ok
Q4: Do yo have a result using the geometrically verified matching?

You’re welcome, I’m curious to see if it resolves

I also noticed that you processed step 1 with Image Scale 0.5
I suggest processing with Full image scale. Let us know how this is going by sharing the new quality report.

Could you also share more information about your sensor? Is it an RGB sensor?

thanks @joan.cano for your insights

1 Like

Hello Christina,

if I select “Full” in “Image Keypoints Scale”, the Image Scale is set to 1/2 (half image size) and I cannot change that, I could select “Custom” and then change image scale to 1?

In the metadata of the images I cannot find any information to vertical coordinate system, so I left it default which then is ellipsoid, can this cause a problem?

The images are taken with a Phase One (iXU150) RGB Camera.

Regards

Hello again,
here is the report from the result using geometrically verified matching:Mosaic_nr5_report_11_09.pdf (1.5 MB)
I compared with other DEMs again and the result is the same as before (to high in northwestern and too low in the southeastern area).
Regards

Could you process only the images of this area?

If you get similar results try with this parameters:

  • Geometrically verified match
  • Gelocation and precise orientation
  • Optimization of internal camera parameters: All prior

Waiting for your results.

I see! Image Scale is set by default to 1/2 (half image size) because of the very high resolution of your sensor. Half image scale should be OK.

From the quality report we see the following selected coordinate systems:

Image Coordinate System: WGS84
Ground Control Point (GCP) Coordinate System: WGS84 /UTMzone 33N

What is the vertical datum of your images and GCPs?
We need to know if images and GCPs are using the same vertical datum, otherwise, the software will need to do some transformations.

Vertical coordinate systems can be selected under the Advanced Coordinate Options: Select Image / GCP / Output Coordinate System

Hello again,
so I got postprocessed geolocations for the images and run the process again. The input altitude vertical coordinate system was the EGM 96 Geoid and the output coordinate system I selected to the same as the GCPs (UTM 33N) and the Ellipsoid as vertical coordinate system. Now when I do DEM differencing (subtracting the generated DEM from another one) the result has improved but instead I get some weird stripe artefacts in the DEM (see image). Any ideas why?

@jehammar, thank you for sharing the comparison. Could you explain from which source are the DEM1 and DEM2 generated?

It looks like the artifacts follow a certain pattern, for example, flight lines. Do you see any correlation between the flight lines in the Pix4Dmapper project?

Best,

Hello,
the DEM1 is the one I have generated with Pix4D, the images are taken from an aircraft. The DEM2 also generated from aerial images taken from an aircraft with photogrammetric methods (not by me). By just looking at the two DEM they look the same but if I subtract DEM1 from DEM2 I get this stripes.
I compared the flight lines with the stripes and they dont really correlate (see image with overlap) because the flight lines are straight.


Best regards

At this point it is very hard to say where the difference comes from or which DEM (from Pix4D or from another source) has the systematic error that is shown when you do the comparison.

It would be best to get an independent source of truth in order to determine what is causing the issue.

I actually found out that the problem with the stripes comes from the other DEM (I compared with a third DEM and there no stripes appeared). So I am happy with my result and my conclusion is to always be aware of what vertical system was used for the images.

best

1 Like