Support Website Contact Support Blog

Step 2 processing going very slowly

Hello everyone, 

I started processing on a new dataset on Saturday morning, and it’s still on sub-step 2/11 (classifying points) 56 hours later. 

Data-set info: 

  1. 500 images
  2. Image resolution (4608 x 3456)
  3. Image size: (about 6.5mb per picture, 3.2GB total) 
  4. All images geo-referenced (DJI Zenmuse X5)

Processing options used: 

  1. Pointcloud Densification: Original image size, multiscale, high point density, 3 min matches)
  2. Pointcloud Classification checked on. 
  3. 3D textured mesh settings: High resolution. 
  4. 12 MTPs 

Our processing rig specs: 

  • CPU: i9 7920x @ 3.8ghz
  • RAM: Corsair Dominator Platinum 64GB @ 3200mhz
  • GPU: EVGA 1080ti
  • SSD: Samsung 960 PRO 1TB

This processing time is quite worrying. We built this rig specifically to tackle pix4d processing, and we expected this data-set to be done in at most 24 hours. 

Any thoughts? 

Hi Alek, 

If there is no error message, the processing is probably still continuing.

The thing that might be a blocker here is that you have set the settings to “high point density” for the point cloud and “high resolution” for the 3D Textured Mesh. This could take a toll on the RAM which might not be sufficient. I would try to reduce these settings and launch the processing again. It should significantly reduce the processing time. Letting this processing finish would be interesting for comparison purposes of the quality of the result VS necessary processing time (if it manages to finish the processing). 

If you could post a link to the log file I can have a look to see if there is something strange. 

Cheers!

I just experienced this myself…it is most likely stuck in the Classification part.  Something is terribly wrong with the classification step from what I have seen so far.

Simply turn Classification off and it will run normally.  You only have 8 gigapixels in the project and that should take 4-6 hours.  You have more than enough RAM…once you get over 50 gigapixels then 64GB won’t be enough.  Although I never use Pix4D to mesh because quite frankly it sucks for meshing but that would need more RAM so an upgrade might be necessary.  I know this is a Pix4D forum but if you want to make the best mesh then look at RealityCapture.

If it is indeed the classification that is slowing down the processing, your feedback is more than welcome. The log file should already help for that.

I tried one project for classification and based on the progress bar it was going to take 5-7 days…so yeah I cancelled it and haven’t tried again.  If I get some open computer time then I can try it again on a smaller project.

I am 100% sure that Alek’s problem is the classification and nothing else because I have nearly the same hardware setup, run nearly the same settings, and run 10X the gigapixels in 24-30 hours.

Hey Pierangelo, Adam, 

It finally finished processing last night. So Adam hit it right on the head. Classification took the lion’s share of the processing time at 2 full days! 

Without the classification, the whole process seems like it would have only taken 24-30 hours, which is completely acceptable and within reason. 

I don’t have access to the log file at the moment, but I will post it later. 

 

 

Hey, 

I got some input from our developers. In version 4.0 the software is slow for the classification of projects with Ground Sampling Distance (GSD) below 5cm. I suspect that this was the case in your projects too. 

In version 4.1 this was improved by doing the classification at a 5cm scale if the GSD is too small. Can you try the same project with the Preview of 4.1 and see if that accelerates the processing? Here is the download link: https://cloud.pix4d.com/download/ 

5cm…well my GSD is typically 1-2mm at most.

I just got done with some RAW testing and will update to the Preview and re-run my last project with classification turned back on.

There is a major issue with the way the latest release of Pix4D handles different types of Nvidia cards.

I have done some comparison tests to prove this and have a support ticket open with P4D. As yet no conclusive response.

I have an i9 Test i91900X - with Quadro7900X machine and a dual Xeon machine.

I have a Quadro K5200 that came with the Xeon machine and a GeForce Titan X (Pascal) in the i9 machine.

When running a 198 image set on the i9 with the GeForce, Step 3 takes a bout 24 hours to complete. Obviously a major issue.

When running a 198 image set on the i9 with the lesser spec Quadro, Step 3 takes very little time at all.

So either the GeForce Titan (Pascal) cards are so exotic that P4D can’t handle them or theres something else a-miss.

I have not tried any other GeForce card.

 

The above issue is present in 4.0.25 and 4.0.18.

Those Titan cards are specialized for AI work so I am not surprised it is slow without changing Nvidia settings like on the Quadro…but Pix4D should be better than that so it will be interesting to hear what they find. You may want to test version 3.3 as well.

GTX is the best GeForce card for Pix4D so you should try that instead of the highly specialized Titan…and GTX is cheaper by far.

The Nvidia Titan X (Pascal) does have GTX written on it…its a high end gaming card. But as you say, it could be too exotic for P4D to handle. However it does use the same GeForce drivers…

Right now, I have uninstalled P4D v 4 and installed 3.3.29 and am re-running my test dataset. Step 1 has just completed. I will report back as to how Step 3 goes.

Yes but the Titan is not the same when you read the specs and reviews…and you are right it shouldn’t be slower than a Quadro but I still say the 1080Ti is the best.

So you don’t face any issues on step 3 with the 1080 Ti?

Well even with 3.9 step 3 is not workable. Back to the Quadro card until I get an answer from P4D as to why Geforce Titan is not properly supported.

@Alek, Pix4D Desktop 4.1.19 was released on Thursday, December 14, 2017. If you have an opportunity to conduct a comparative test of overall processing time between 4.0 and 4.1 with the project configuration you outlined above, we would greatly appreciate it if you shared your results. You can already download the latest version of Pix4D Desktop at https://cloud.pix4d.com/download/,

@Philip and Adam, I anticipate that the the extended processing time that Philip experienced with his NVIDIA GeForce GTX Titan X Pascal and that Alek experienced with the project configuration he described above are caused by different factors. To stay informed about the status of the Titan X investigation, please go to https://community.pix4d.com/t/4284. More information will be shared as soon as we have an update.