Support Website Contact Support Blog

Pix4Dcapture crashes with Parrot ANAFI firmware v1.7 in Android

It’s not possible to run Pix4Dcapture in Andorid (I’ve tried on a Samsung A70 with Android 10 and on a Moto E4 plus with Android 7) with Skycontroller 3 connected to the phone. It doesn’t happen while the controller is disconnected.

Anyone else with the same problem?

1 Like

By the way, I’ve noticed it doesn’t happen with does drones that haven’t been updated to lastest firmware version.


Yes, I can confirm I have the same problem after update to newest version of Parrot Anafi firmware.


Yes, I’m having the same issues after firmware update


Yesterday I tested the Pix4dCapture with last updates, anfi FW, SK3 and the FF6 I got the same issue as other pilot so I connected another android device with FF6 older version and have no any issues
It is clear that the new version FF6 is messing up the app


Same here. Anafi Thermal + Android. As soon I upgraded to v1.7 it didnt work anymore with Pix4D.
Are there other options for setting auto flights for the Anafi?

Same issue here on Motorola One. Pix4DCapture app crashes when connected to the skycontroller. Most recent firmware versions are installed and the most recent versions of the Freeflight/Pix4DCapture app.

I’m afraid there’s not. It would be nice to know if Pix4D is working on this. It’s really a mess.

Hi All,

The Parrot Anafi won’t work with the recent firmware update of 1.7.3. We will release a new version for Pix4Dcapture android within a few weeks and it should work with that version.

For now, the only option is not updating the firmware to 1.7 or using the iOS version of the Pix4Dcapture app.


Is there a link we can have to install previous version there is no way i can wait a couple of weeks for a new version to be released?


You guys are kidding me right?!!
I had a phone call with sales last week, bought the software and now I can’t use it!!! Typical.

Hola, ya tendrán resuelto la compatibilidad del anafi con Pix4D?
Mi equipo se actualizo el pasado 23 de octubre de 2020 y ya no puedo usarlo…
Cómo desinstalo el firmware 1.7.3 y regreso a la anterior?

Hi All,

We released a new version of Pix4Dcapture 4.10.0 for android. You should now be able to upload the mission in the Anafi drone with firmware 1.7.3.

Warning: When you test the software, make sure to have a good satellite connection before you upload the mission. The poor satellite number will result in failure to upload the mission.


1 Like

Hola, me temo informarle que la versión de Pix4D instalada en mi equipo es el 4.10.0 y se interrumpe cuando se enlaza con el dron anafi con versión de firmware 1.7.3
Que puedo hacer?

Since updating the Pix4dCapture app to 4.10.0 our Anafi drone cannot launch because it says Homepoint location is unknown. It’s like it thinks it doesn’t have enough satellites. Hopefully this will be fixed soon.

I have a problem when using the Pix4Dcapture app with ANAFI. When I start the drone with the app it doesn’t connect to the satellites.
I have already uninstalled the app and changed device.
I have already been in touch with Parrot who are saying that if the drone works with FreeFlight (which is working properly) the problem isn’t with the drone but with Pix4Dcapture.
I am using 4.10.0 for android on Huwawei P20.
A reply would be appreciated
Many thanks

@Kapil_Khanal warned about this in the last update. I was informed by other users about this issue, too.

Hello all,

I’m new to this and I’m struggling to get my parrot anafi to connect to the pix4d capture app. I have the cntl+parrot app installed.

So I turn on the drone then connect through the free flight 6 app. Close that app out then connect throuhht the cntl+ app? I have tried different ways/ orders to connect but with no success and I am not sure what I am doing wrong. Any information would be helpful.

Thank you