Support Website Contact Support Blog

Images corrupted after synchronization

Hello,

I flew a mission in the field and synchronized the images back home. The mission manager was misbehaving badly and had to restart the app and the copying process several times. At the end I got all the data but some images are corrupted. For example an image is 0 bytes, and another one has an associated .t file which looks like the original image before the exif rewriting.

It looks like the app crashed while copying those files, and some temporary files have been left around. Is there a way to restart the process from zero? I still have the images on the drone sd card, but the mission manager shows the mission status as “copied from drone”.

Thank you

I experienced quite a few app crashes while syncing from the drone with missions of 100+ images. The way to restart the process is to tweak the .json files associated with the mission as follows:

In mission_details.json

  • mProjectSyncStateQuick set to INIT, not to DOWNLOADED
  • mProjectSyncStateFull set to INIT, not to DOWNLOADED

And correspondingly in syncState.json

  • first set to INIT, not to DOWNLOADED
  • second set to INIT, not to DOWNLOADED

At least this worked for me. When I got app crashes again, I was at least able to finish the sync, and get a full uncorrupted set of images between the first and second round.

Any comments appreciated.

Hi Daniele,

Thank you for sharing your feedback and the workaround. We are glad to read that it finally worked for you.
Have you tried to recently fly with our latest versions of Pix4Dcapture?

If you have any suggestions or remarks, please also provide the model of the drone and device, that will be very helpful.

Regards,