Support Website Contact Support Blog

Elevation off by ~200'

Hello, I am using the DJI Phantom 4 pro. I have set up a grid mission for a site and collected the data without a problem. After processing the data on the cloud, I have downloaded the project to work with in Pix4Dmapper desktop. My desired output are contour lines at a 2’ interval. After processing I added the contours to ArcGIS and noticed the vertical elevations are off about 200’ in some instances. I do have ground control points and re-process using a vertical shift between the model and GCPs (which take a lot of time). I was wondering if you could give me an idea on what may be causing the large difference in vertical elevation? I was under the assumption that the elevations would be a little off, but not that far off. Thanks a lot!

Hello Jeff,

If you use GCPs, the project will be tied to them so there is no need to apply any shift, the software will compute it automatically.

AS I understand from your comment, “I do have ground control points and re-process using a vertical shift between the model and GCPs”, you are applying a shift. if that is the case, you should not apply, it will be computed automatically.

Anyway, if you can share the Quality Report, we can have a look at it.

Thank you very much.

Thanks for the response. I wonder if I am using the GCPs incorrectly. When I initially open the project I launch rayCloud and then use the GCP/MTP Manager to import the GCPs. When the GCPs are added they are about 200 feet above the point cloud surface. That is why I used the Vertical shift to bring he point cloud surface to the GCP elevation. I am not sure if the problem is a setting on the drone camera or a setting in Pix4D that is causing such a big difference in elevation. I am using a DJI Phantom 4 Pro. In the past I used the DJI Phantom 3 and the elevations were much closer to what they are supposed to be. 

Unfortunately the Quality Report is too large to attach. Any recommendation on how to send would be great.

Again, thanks a lot for your assistance. 

Jeff

Hello Jeff,

It is quite common that some drones write the Z value wrongly in the EXIF tags.

That is what is happening to you. The Z coordinate is totally wrong and the GCPs are displayed over the terrain.

Please have a look at these articles: How to correct for wrong image altitude without GCP and Vertical shift between model and the GCPs

 

 

The easiest way to overcome this problem would be to correct the altitude in the Image Properties Editor right after importing the images. If you apply a shift to the geotags, that is also equivalent.

Regards.