Support Website Contact Support Blog

[Desktop][Pix4dMapper] Large RMS error and unverified GCPs for merged project

I recently merged several sub-projects into one. After the merge, I noticed that several of my GCPs were highlighted red and the quality report said they were unverified (ie 4/8 in the _Verified/Marked _column). I am also experiencing large accuracy problems with the newly merged project. RMS error is quite high as well. For example RMS error is 4.6 ft in X, 54.2 ft in Y and 42.3 ft in Z. These are obviously unacceptably high.

How do I fix my accuracy problems?

Here is a link to my Quality Report:

https://drive.google.com/drive/folders/1aENJABBFShyzSPje8SePusd-wFN_EUTc

 

Hi Nicholas, 

Thanks for describing the issue and sharing a link to the quality report. Unfortunately, the link you shared has restricted access, I’ve asked permissions to view it. Feel free to edit your post to share a public link to the quality report. 

I will follow-up once I had a look at the quality report. In the meantime, could you describe in more detail how you proceeded to merge the projects? e.g. how many subprojects, were the GCPs added in several subprojects,…this will also help to understand the situation. Thanks!

Sorry I thought I had made that shareable, my mistake. Here it is again:

https://drive.google.com/drive/folders/1aENJABBFShyzSPje8SePusd-wFN_EUTc?usp=sharing

 

The project is a long corridor mapping project. It was flown with the DJI Phantom 4 pro at an altitude of 150 feet with 80 frontal & 60 side overlap. There were a total of 8 flights. I initially processed the project into 4 sub-projects of 2 flights each to make the project a bit more manageable. After doing the initial processing on the 4 sub-projects I noticed a gap between flights 1 and 2 which produced 2 blocks in section 1. I returned for another flight to connect these 2 flights. So the project then became 5 sub-projects. GCPs were indeed added to each sub-project, there are a total of 8 GCPs. I then added MTPs with names and points in common between the various sub-projects and reoptimized. I then merged the project as per the merge project step-by-step instructions reoptimizing after every step. Upon inspection of the quality report and verification that 1 block had been created in step 15 of the step-by-step, I noticed the huge accuracy errors. I decided to reoptimize to see if that would fix it, it did not. I then created a new file and remerged the sub-projects and I added more MTPs along the corridor in an attempt to fix these to no avail (it actually made it worse). 

 

Thanks for sharing the new link and for the description. 
I noticed two points in the quality report: 

  1. Camera optimization

If we have a closer look at the individual camera models from each subproject: 

a) Seems ok.

b) Large differences about 46%

c) Smaller, but still large differences about 8%

d) Smaller but still large

 

e) too large


In summary, I would verify in the subprojects if the camera optimization is green in the quality report summary (<5% change). If not and as the camera is a known camera in the Pix4D camera database. I would suggest to use All Prior in Processing Options > Initial Processing > Calibration > Internal parameters optimization. This tells the software to stay closer to initial parameters during the optimization. 

  1. GCP accuracy

The default accuracy values of GCPs are 0.02 meters. If you have a project in feet, the accuracy of the GCPs needs to be adapted. In this case, if you’d like to keep the default values it should be 0.066 ft. Also, I would verify the marks you have added for the GCPs in the images, as there seem to be very high errors, especially on the Z axis. 


The accuracy of the GCPs can be edited in Project > GCP/MTP Manager. I would make sure that each subproject is well processed with these parameters before merging them. 

These two points should already significantly improve the project, please post updates once you could try them. :slight_smile:

Thank you for your feedback. I will be working on this over the next couple days and will post my results once I’ve finished.

Okay, here are the changes and results.

  • I changed the internal parameters _optimization _to _All prior _in all the sub-projects which made all of the check marks green .
  • After that I verified the marks of all my GCPs and their coordinates. They were all correctly marked and input.
  • Then I changed the accuracy to .06 ft and because I only need them to be horizontally accurate I changed them to 2D GCPs.
  • I then re-merged the sub-projects.

The result is much better, but issues remain. 1 GCP is not verified still and the RMS error is around 10 ft. See the quality report below:

https://drive.google.com/file/d/1qfoJEq1Y3YcRN0KFBBATG2DffCz-_z-7/view?usp=sharing

I need the accuracy of the orthomosaic to be about an inch (0.08 ft). Any other suggestions to get this level of accuracy?

 

Thanks for detailing the steps you have taken.

Have you reoptimized (Process > Reoptimize) each subproject separately before merging? This should make sure that the new settings for the accuracy, the 2D GCP and the marks are correctly taken into account. 

If we have a closer look at the GCPs, the errors are on points 101, 102 and 103. Also point 105 does not have any verified marks. Do you see something specific related to these points that could create such high errors? 

The points 104, 106, 107 and 108 seem to be as expected. Something that could help, is if you show where each of these points is in the project and how you have separated the project into subprojects. 


Based on the quality report it’s hard to tell how the GCPs are placed, if they are in a straight line or in a zig-zag pattern. For future reference, I suggest to read this article: Number and Distribution of Ground Control Points (GCPs) in Corridor Mapping.


Looking forward to an update.