Support Website Contact Support Blog

Using Google map as background map

Gracias Michael. A mi también me funcionó.

 Michael Turner’s URL worked well. in the setting option of Pix4Capture while selecting the basemap provider press “+” icon, type name and in URL space type  

http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z}&s=GaEnjoy and thanks to Michael Turner.

any update on the google crystal sky thing???

Hi Craig,

The DJI CrystalSky is now supported with Pix4Dcapture.
You can have a look at the procedure about how to install the latest APKs of our application on it here.

Best,

Base map displayed in Pix4dmapper is at least 4 years old at may location. Could you please explain in a simple way to “how to use google map in pix4dmapper…?”

Pix4D, can you please me how to update the basemap in Pix4D Mapper.  The one that is being used is VERY VERY old!  @arif03 arif03 has stated the same above.

Hi Tim,

The default basemap used in Pix4Dmapper is Mapbox and it is currently not possible to choose another one. It can indeed lead to outdated content in some locations.
The request to be able to choose a basemap provider to get updated maps has been shared with the developer’s team so that they consider to implement it in the future.

We will keep you updated on this thread if any news.

Best,

I just tried these links on iOS and it worked:

-Satellite: http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z}&s=Ga
-Street: https://mt0.google.com/vt/lyrs=m&hl=en&x={x}&y={y}&z={z}&s=Ga

Open the Pix4DCapture >> Settings >> Map >> Add on STREET BASEMAP PROVIDER (https://mt0.google.com/vt/lyrs=m&hl=en&x={x}&y={y}&z={z}&s=Ga) >> Add on SATELLITE BASEMAP PROVIDER (http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z}&s=Ga)

1 Like

Thanks Paulo!!  

1 Like

Many Thanks for Michael Turner - URL is Worked.

Thank
http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z}&s=Ga

It work for me too, i just copy from this comment, i figure where it come from

Hi all, I’m on iOS and have used the above links to add Google as “street basemap provider” and “satellite basemap provider” and have ticked these ones in settings, but my imagery looks exactly the same. Is there somewhere else where they need to be selected? In the “default basemap provider” area Mapbox and Apple are still the only two options. Am I missing something?

Hi Cameron,

Have you been through the following procedure to define a custom basemap provider?

Best regards,

Hi Gael, yes I did.

Hi Cameron,

I tried the URL provided in Michael Turner comment and it worked fine.

Can you double check:

  • That the URL entered is correct.
  • Compare in a location where for example there are clouds on MapBox so that you can see the difference when setting up the new basemap provider.

If it still does not work, I can suggest you a clean reinstall of the application following the procedure below:

Caution

The procedure below may imply data loss so we recommend to make a backup if there are important data saved. Connect the mobile device and use iTunes to backup files on your computer.

Re-install Pix4Dcapture from scratch

  1. Uninstall Pix4Dcapture. On your mobile device go to Settings > General > iPhone Storage > Pix4Dcapture > Delete App.
  2. Re-install the latest version of Pix4Dcapture.
  3. (optional) Place the backup content back into the Pix4D folder to restore data.

Best,

Thank you Michael Turner!