Support Website Contact Support Blog

DJI Controller - Mavic 2 Pro - Pix4D No Connection

Thank you for your suggestion, and I do understand the point you are trying to make. I would definitely forward this to the developer team. From the different community posts related to DJI smart controller, it looks like the Litchi is working in the DJI smart controller. I would recommend you to try that. Just to let you know, you can use any image acquisition app and still analyze the data using Pix4Dmapper.

I also am trying to connect the DJI Smart Controller to the Mavic2Pro with Ctrl+DJI for planned missions.
Installing the Pix4DCapture and Ctrl+DJI app are cumbersome, but possible, and both seem to be working properly.
The issue seems to be in connecting Ctrl+DJI to the drone in smart controller.
I have no problems switching back and forth from DJI GO4 to Pix4Dcapture with the standard controller with IOS and I assume it is working with Android as well.
Why has Pix4D not corrected their software to make the connection to the drone?
The Software has been released for almost 6 months!
Getting the app to connect to the drone should be such an easy update!
A lot of your customers seem to be requesting this update, including myself.
I really like the Pix4D app and I really like the DJI Smart Controller, primarily because it allows a much simpler connection process compared to using my iphone and the battery life is much longer on the Smart Controller. The whole system is simpler and more professional using the Smart Controller than connecting a smart phone to a standard DJI controller.
Please make this update happen soon.


Hello @drone6survey,

Thank you for sharing your feedback and the suggestion. We apologize for any inconvenience caused. At the moment, supporting the DJI Smart Controller is not in our timeline. From the different community posts related to DJI smart controller, it looks like the Litchi is working in the DJI smart controller. I would recommend you to try that. Just to let you know, you can use any image acquisition application and still analyze the data using Pix4Dmapper.


Is there a way to create a double grid mission in Pix4Dcapture and export it to Litchi? I am using a smart controller and looking for the best work around to the compatibility issue.




You won’t be able to export the mission from the Pix4Dcapture app and import it to other image acquisition software. And, also the DJI smart controller is not supported by Pix4Dcapture app.


I am aware of the incompatibility issue, that was why I was planning on using Litchi to capture the images. If I have to create the grid in Litchi, are there any best practices you can recommend for gimbal angle and distance between shots? I want to try to replicate the Pix4Dcapture grid as closely as possible to help with the processing of the images.


The best practices for any image acquisition is to have proper overlaps (75% front and 75% side overlap) during the flight. Regarding the camera angle, if you are generating the 3D point cloud, it is always better to have some offset(around 10 degree) in the camera angle rather than Nadir camera position.
We are not families with the setting of the Litchi app, but overall idea is to have enough overlap during the image acquisition. We are also open to see if anyone having the experience with the software can share their opinion.


Pix4DCapture is now working with DJI Smart Controller
This makes me so happy!

You must update DJI to latest version and then update Pix4DCapture to latest version
I did a quick test and it works perfectly.

You have to install the DJI update through DJI Assistant and it takes almost 2 hours.
but it works!
No more running out of phone battery.

Thankyou to both DJI and Pix4D for getting this done


Hi Kapil

Are you aware that Pix4dCapture now works with DJI drones with the smart controller?
Works awesome.

Both DJI and Pix4d should be congratulated for getting this done


THANKS!!! I will check it out when I get home from work today. Great News!!!

Hey drone6survey. H
ow exactlly did you make the update for DJI?

First you need to update the smart controller firmware using dji assistant 2. After that, you have to download the APK files for Pix4d capture V4.7 and Ctrl DJI V1.9.7. I found both online at Transfer the files to a SD card, then put it in your controller (make sure controller is off when you take out and put it in the card). Once the SD card is loaded, turn on your controller, go to the file manager, select SD card at the bottom of the screen and then open the cntrl dji v1.9.7 apk. Follow the install prompts and repeat for the Pix4D v4.7. Once both apps are installed you should be able to open them and connect to your drone. If you don’t have latest version of firmware and apps installed, it won’t work.

Note: the smart controller needs to be updated with dji assistant 2 app. If you try to do it without it just using the controllers connection to the internet, it won’t work properly. Then you will have to uninstall it and reinstall it using dji assistant 2.

I want to emphasize it has to be CTRL+DJI v1.9.7. The current one on google play is v1.9.9. which does not work.

I simply connected the drone and the smart controller to the computer using the mini usb cable
and used the latest DJI assistant to update both.
I then simply pasted the apk for PIX4D v4.7 to the smart controller and intalled over previous version.
I did not update Cntrl DJI and do not seem to need it to run Pix4D Capture

Did some test flights and it works perfectly

Hi all,

I have installed latest firmware by DJI assistant 2, using SD card I have installed CTRL+DJI ver. 1.9.9 and Pix4D ver. 4.8.0 to my SC. I have connected to my Mavic 2 Pro. Seems that everything works properly. The only problem is video feed. It works only the first time when tap the screen option. When I go to map and then back to screen then is black window. Any idea ?

I do not see any difference between CTRL+DJI 1.9.7 and 1.9.9. Both versions work the same and both have problem with video feed.

Is anyone else having problems with Capture not enabling auto focus and auto exposure?
Shot 5 missions on Monday and then realized when processing that the photo’s are all grainy and out of focus!
Thousands of photos that are garbage.
Is there a way to verify that AF and AE are enabled while in mission?
Note; this is while using Capture in Smart Controller and Mavic2 Pro.
Have also had a few issues with Capture disconnecting while in mission and needing to be restarted, but mission continues normally, as the mission is loaded in the drone.

Need to get this working, Using the smart controller I can now use the drone for hours at a time as the controller can charge while in use using usb charger and with the 4 bay DJI charger I am able to keep the 5 batteries in constant rotation.

I have verified that AF and AE are enabled in DJI GO4 and all software is up to date.


We are aware of some issues with the image focus when flying the DJI Mavic Pro. These issues seem to happen randomly as no clear pattern was identified so far. At the moment we recommend to try the procedure below. Developers are looking to find a solution so that it can be fixed in a future release.

Recommendations :

  1. Setup the focusing action to C1/C2 of the remote controller (prior to the flight, in DJI GO).
  2. Fly the drone to the first waypoint and press C1/C2 to focus using DJI GO.
  3. Quit DJI GO app and Start the mission in Pix4Dcapture.


Hi Kapil ,and every one else who is having problems with focus and exposure with Mavic 2 Pro.
There is a long list of people with this problem in another thread.
Today I re shot a survey I did on Monday.
I tried a different tack.
I started in DJI GO and focused to distant object and locked the exposure at 200 and set focus to manual, locking the focus.
I then switched the program directly to Pix4D Capture without going through Ctrl+DJI .
It seems that if the Smart Controller is already connected to the drone there is no need to run through Ctrl+DJI!
In Pix4D, I started the mission as normal on the ground and let the software complete the mission autonomously without any issues.
Photo’s appear very high definition when downloaded directly from Drone with micro USB cable. I tried to follow the above directions, but could not restart Pix4D and admit it is a little disconcerting dissconecting from the software while in the air.
I am using the smart controller with the latest and most current software for both the smart controller, the drone and Pix4D
I hope this helps all the other users of the Mavic2 Pro